summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-07-08 22:34:28 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-07-08 22:34:28 +0000
commita7ed2ccf93297d388726f7910a93b9c277ba5b43 (patch)
treeec1e0968beaa675657a09abcf330e4821282bcda /dev-lang/swig
parentremove spider and add media-optical. (diff)
downloadgentoo-2-a7ed2ccf93297d388726f7910a93b9c277ba5b43.tar.gz
gentoo-2-a7ed2ccf93297d388726f7910a93b9c277ba5b43.tar.bz2
gentoo-2-a7ed2ccf93297d388726f7910a93b9c277ba5b43.zip
split USE='tcltk' to 'tcl' & 'tk' per bug #17808. Nuked X USE flag since it was only to find tk from tcltk
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'dev-lang/swig')
-rw-r--r--dev-lang/swig/ChangeLog7
-rw-r--r--dev-lang/swig/swig-1.3.21.ebuild14
-rw-r--r--dev-lang/swig/swig-1.3.25.ebuild12
-rw-r--r--dev-lang/swig/swig-1.3.27.ebuild14
-rw-r--r--dev-lang/swig/swig-1.3.29.ebuild14
5 files changed, 29 insertions, 32 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index 612e956635e1..53e99589e547 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/swig
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.67 2006/07/07 14:02:20 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.68 2006/07/08 22:34:28 cardoe Exp $
+
+ 08 Jul 2006; Doug Goldstein <cardoe@gentoo.org> swig-1.3.21.ebuild,
+ swig-1.3.25.ebuild, swig-1.3.27.ebuild, swig-1.3.29.ebuild:
+ split USE='tcltk' to 'tcl' & 'tk' per bug #17808. Nuked X USE flag since it
+ was only to find tk from tcltk
07 Jul 2006; Chris Gianelloni <wolf31o2@gentoo.org> swig-1.3.25.ebuild:
Stable on x86 and amd64 for bug #139505.
diff --git a/dev-lang/swig/swig-1.3.21.ebuild b/dev-lang/swig/swig-1.3.21.ebuild
index 0be9e71e74fb..caf4cbbe9c63 100644
--- a/dev-lang/swig/swig-1.3.21.ebuild
+++ b/dev-lang/swig/swig-1.3.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.21.ebuild,v 1.32 2006/01/07 19:04:31 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.21.ebuild,v 1.33 2006/07/08 22:34:28 cardoe Exp $
inherit flag-o-matic mono #48511
@@ -11,17 +11,15 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390 sh ppc64"
-IUSE="doc java guile python tcltk ruby perl php X"
+IUSE="doc java guile python tcl tk ruby perl php"
DEPEND="virtual/libc
python? ( >=dev-lang/python-2.0 )
java? ( virtual/jdk )
ruby? ( virtual/ruby )
guile? ( >=dev-util/guile-1.4 )
- tcltk? (
- dev-lang/tcl
- X? ( dev-lang/tk )
- )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
perl? ( >=dev-lang/perl-5.6.1 )
php? ( virtual/php )"
@@ -48,13 +46,13 @@ src_compile() {
`use_with java javaincl "${JAVA_HOME}/include"` \
`use_with ruby ruby /usr/bin/ruby` \
`use_with guile` \
- `use_with tcltk tcl` \
+ `use_with tcl` \
`use_with perl perl5 /usr/bin/perl` \
`use_with php php4` \
|| die
# fix the broken configure script
- use tcltk || sed -i -e "s:am__append_1 =:#am__append_1 =:" Runtime/Makefile
+ use tcl || sed -i -e "s:am__append_1 =:#am__append_1 =:" Runtime/Makefile
`has_version dev-lisp/plt` && PLT=/usr/share/plt/collects
`has_version dev-lisp/mzscheme` && PLT=/usr/share/mzscheme/collects
diff --git a/dev-lang/swig/swig-1.3.25.ebuild b/dev-lang/swig/swig-1.3.25.ebuild
index 4701f45d9c11..d85e5120d6d1 100644
--- a/dev-lang/swig/swig-1.3.25.ebuild
+++ b/dev-lang/swig/swig-1.3.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.25.ebuild,v 1.9 2006/07/07 14:02:20 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.25.ebuild,v 1.10 2006/07/08 22:34:28 cardoe Exp $
inherit flag-o-matic mono eutils #48511
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ~ppc-macos ppc64 ~s390 ~sparc x86"
-IUSE="doc guile java perl php python ruby tcltk X"
+IUSE="doc guile java perl php python ruby tcl tk"
DEPEND="virtual/libc
guile? ( >=dev-util/guile-1.4 )
@@ -20,10 +20,8 @@ DEPEND="virtual/libc
php? ( virtual/php )
python? ( virtual/python )
ruby? ( virtual/ruby )
- tcltk? (
- dev-lang/tcl
- X? ( dev-lang/tk )
- )"
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
src_compile() {
strip-flags
@@ -42,7 +40,7 @@ src_compile() {
$(use_with php php4) \
$(use_with python python python) \
$(use_with ruby ruby /usr/bin/ruby) \
- $(use_with tcltk tcl) \
+ $(use_with tcl) \
|| die
has_version dev-lisp/mzscheme && PLT=/usr/share/mzscheme/collects
diff --git a/dev-lang/swig/swig-1.3.27.ebuild b/dev-lang/swig/swig-1.3.27.ebuild
index 37d4e7a0ee34..ec4b9bbfe669 100644
--- a/dev-lang/swig/swig-1.3.27.ebuild
+++ b/dev-lang/swig/swig-1.3.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.27.ebuild,v 1.4 2006/02/17 16:34:52 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.27.ebuild,v 1.5 2006/07/08 22:34:28 cardoe Exp $
inherit flag-o-matic mono eutils #48511
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc guile java lua mono ocaml perl php pike python ruby tcltk X"
+IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
RESTRICT="test"
DEPEND="lua? ( dev-lang/lua )
@@ -24,10 +24,8 @@ DEPEND="lua? ( dev-lang/lua )
python? ( virtual/python )
ocaml? ( dev-lang/ocaml )
ruby? ( virtual/ruby )
- tcltk? (
- dev-lang/tcl
- X? ( dev-lang/tk )
- )"
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
src_compile() {
strip-flags
@@ -39,8 +37,8 @@ src_compile() {
fi
econf \
- $(use_with X x) \
- $(use_with tcltk tcl) \
+ $(use_with tk x) \
+ $(use_with tcl) \
$(use_with python python python) \
$(use_with perl perl5 /usr/bin/perl) \
$(use_with java java "${JAVA_HOME}") \
diff --git a/dev-lang/swig/swig-1.3.29.ebuild b/dev-lang/swig/swig-1.3.29.ebuild
index 280dea4416f3..f90ffd697990 100644
--- a/dev-lang/swig/swig-1.3.29.ebuild
+++ b/dev-lang/swig/swig-1.3.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.29.ebuild,v 1.1 2006/05/22 05:46:19 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.29.ebuild,v 1.2 2006/07/08 22:34:28 cardoe Exp $
inherit flag-o-matic mono eutils #48511
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc guile java lua mono ocaml perl php pike python ruby tcltk X"
+IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
RESTRICT="test"
DEPEND="lua? ( dev-lang/lua )
@@ -24,10 +24,8 @@ DEPEND="lua? ( dev-lang/lua )
python? ( virtual/python )
ocaml? ( dev-lang/ocaml )
ruby? ( virtual/ruby )
- tcltk? (
- dev-lang/tcl
- X? ( dev-lang/tk )
- )"
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
src_compile() {
strip-flags
@@ -39,8 +37,8 @@ src_compile() {
fi
econf \
- $(use_with X x) \
- $(use_with tcltk tcl) \
+ $(use_with tk x) \
+ $(use_with tcl) \
$(use_with python python python) \
$(use_with perl perl5 /usr/bin/perl) \
$(use_with java java "${JAVA_HOME}") \