summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-24 07:05:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-24 07:05:49 +0000
commit3a551266af38746e4e7dd30c677e653642127afb (patch)
tree98edb2fb43d5aedf6a651b1b810767014b9f4eb1 /dev-lang/parrot
parentUse QA_PREBUILT Bug #430662 (diff)
downloadgentoo-2-3a551266af38746e4e7dd30c677e653642127afb.tar.gz
gentoo-2-3a551266af38746e4e7dd30c677e653642127afb.tar.bz2
gentoo-2-3a551266af38746e4e7dd30c677e653642127afb.zip
Bump
(Portage version: 2.2.0_alpha160/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog9
-rw-r--r--dev-lang/parrot/parrot-4.4.0.ebuild86
-rw-r--r--dev-lang/parrot/parrot-4.5.0.ebuild83
-rw-r--r--dev-lang/parrot/parrot-4.7.0.ebuild83
-rw-r--r--dev-lang/parrot/parrot-4.8.0.ebuild83
-rw-r--r--dev-lang/parrot/parrot-4.9.0.ebuild83
-rw-r--r--dev-lang/parrot/parrot-5.0.0.ebuild (renamed from dev-lang/parrot/parrot-4.6.0.ebuild)6
7 files changed, 11 insertions, 422 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 89cafb3e71f8..33cd0c7e2be2 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.62 2013/01/06 06:22:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.63 2013/01/24 07:05:49 patrick Exp $
+
+*parrot-5.0.0 (24 Jan 2013)
+
+ 24 Jan 2013; Patrick Lauer <patrick@gentoo.org> +parrot-5.0.0.ebuild,
+ -parrot-4.4.0.ebuild, -parrot-4.5.0.ebuild, -parrot-4.6.0.ebuild,
+ -parrot-4.7.0.ebuild, -parrot-4.8.0.ebuild, -parrot-4.9.0.ebuild:
+ Bump
*parrot-4.11.0 (06 Jan 2013)
diff --git a/dev-lang/parrot/parrot-4.4.0.ebuild b/dev-lang/parrot/parrot-4.4.0.ebuild
deleted file mode 100644
index e19a10ce9e13..000000000000
--- a/dev-lang/parrot/parrot-4.4.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.4.0.ebuild,v 1.1 2012/05/18 02:12:11 patrick Exp $
-
-EAPI=3
-
-# There's multiple small issues at the moment, so ...
-RESTRICT="test"
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.5.0.ebuild b/dev-lang/parrot/parrot-4.5.0.ebuild
deleted file mode 100644
index 289f6c834d78..000000000000
--- a/dev-lang/parrot/parrot-4.5.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.5.0.ebuild,v 1.1 2012/06/20 08:10:20 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.7.0.ebuild b/dev-lang/parrot/parrot-4.7.0.ebuild
deleted file mode 100644
index 7969631a85da..000000000000
--- a/dev-lang/parrot/parrot-4.7.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.7.0.ebuild,v 1.1 2012/08/23 03:23:04 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.8.0.ebuild b/dev-lang/parrot/parrot-4.8.0.ebuild
deleted file mode 100644
index 6995b21f86ad..000000000000
--- a/dev-lang/parrot/parrot-4.8.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.8.0.ebuild,v 1.1 2012/10/05 04:45:27 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.9.0.ebuild b/dev-lang/parrot/parrot-4.9.0.ebuild
deleted file mode 100644
index fb7380d480f3..000000000000
--- a/dev-lang/parrot/parrot-4.9.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.9.0.ebuild,v 1.1 2012/10/30 04:04:49 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/supported/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.6.0.ebuild b/dev-lang/parrot/parrot-5.0.0.ebuild
index 610212a8b402..578650238023 100644
--- a/dev-lang/parrot/parrot-4.6.0.ebuild
+++ b/dev-lang/parrot/parrot-5.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.6.0.ebuild,v 1.1 2012/07/19 06:05:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-5.0.0.ebuild,v 1.1 2013/01/24 07:05:49 patrick Exp $
EAPI=3
@@ -8,7 +8,7 @@ inherit eutils multilib
DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/stable/${PV}/${P}.tar.bz2"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/stable/${PV}/${P}.tar.gz"
LICENSE="Artistic-2"
SLOT="0"