summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-25 21:30:23 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-25 21:30:23 +0000
commit1823f2a7ea5beaeb280a78d3958da3d5a9b51d05 (patch)
treefd42e2bb5060ae089a9fe01070b1f76a07afa3e9 /dev-lang/mono/mono-1.2.4.ebuild
parentMarked ppc stable for bug #182391. (diff)
downloadgentoo-2-1823f2a7ea5beaeb280a78d3958da3d5a9b51d05.tar.gz
gentoo-2-1823f2a7ea5beaeb280a78d3958da3d5a9b51d05.tar.bz2
gentoo-2-1823f2a7ea5beaeb280a78d3958da3d5a9b51d05.zip
dev-lang/mono: added warnings regarding build failures on systems with active SELinux/PIE+SSP/grsec/PAX and other security enhancements (addressing bug #153781)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/mono/mono-1.2.4.ebuild')
-rw-r--r--dev-lang/mono/mono-1.2.4.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-lang/mono/mono-1.2.4.ebuild b/dev-lang/mono/mono-1.2.4.ebuild
index 3815f6cc33c8..c277a40a53ef 100644
--- a/dev-lang/mono/mono-1.2.4.ebuild
+++ b/dev-lang/mono/mono-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.6 2007/06/16 11:58:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.7 2007/06/25 21:30:23 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -86,7 +86,15 @@ src_compile() {
# Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
# I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
+ LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+
+ if [[ "$?" -ne "0" ]]; then
+ ewarn "If you are using any hardening features such as"
+ ewarn "PIE+SSP/SELinux/grsec/PAX then most probably this is the reason"
+ ewarn "why build has failed. In this case turn any active security"
+ ewarn "enhancements off and try emerging the package again"
+ die
+ fi
}
src_install() {