summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-12-14 20:05:37 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-12-14 20:05:37 +0000
commit613203ea438c63e90c73b9b813c19c93fdae362b (patch)
tree56211cd7c97a3603932666813c14e5318fd78e11 /dev-lang/mono-basic
parentdev-lang/mono-1.2.6: Version bump (bug #202191) (diff)
downloadgentoo-2-613203ea438c63e90c73b9b813c19c93fdae362b.tar.gz
gentoo-2-613203ea438c63e90c73b9b813c19c93fdae362b.tar.bz2
gentoo-2-613203ea438c63e90c73b9b813c19c93fdae362b.zip
dev-lang/mono-basic-1.2.6: version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-lang/mono-basic')
-rw-r--r--dev-lang/mono-basic/ChangeLog7
-rw-r--r--dev-lang/mono-basic/files/digest-mono-basic-1.2.63
-rw-r--r--dev-lang/mono-basic/mono-basic-1.2.6.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-lang/mono-basic/ChangeLog b/dev-lang/mono-basic/ChangeLog
index 689953b687ed..debd7b205960 100644
--- a/dev-lang/mono-basic/ChangeLog
+++ b/dev-lang/mono-basic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono-basic
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/ChangeLog,v 1.7 2007/09/10 19:26:47 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/ChangeLog,v 1.8 2007/12/14 20:05:36 jurek Exp $
+
+*mono-basic-1.2.6 (14 Dec 2007)
+
+ 14 Dec 2007; Jurek Bartuszek <jurek@gentoo.org> +mono-basic-1.2.6.ebuild:
+ Version bump
*mono-basic-1.2.5 (10 Sep 2007)
diff --git a/dev-lang/mono-basic/files/digest-mono-basic-1.2.6 b/dev-lang/mono-basic/files/digest-mono-basic-1.2.6
new file mode 100644
index 000000000000..92afe73bbbb8
--- /dev/null
+++ b/dev-lang/mono-basic/files/digest-mono-basic-1.2.6
@@ -0,0 +1,3 @@
+MD5 c33df73a581d38b79e0d20019878f70f mono-basic-1.2.6.tar.bz2 1164595
+RMD160 8f86eae90e9c2dc3099e2691bb0ba4193aef7d3b mono-basic-1.2.6.tar.bz2 1164595
+SHA256 42aa201f6bccf90af7cbcd405d198fb36d99e839d4e371c2ea7c6704b84c36c8 mono-basic-1.2.6.tar.bz2 1164595
diff --git a/dev-lang/mono-basic/mono-basic-1.2.6.ebuild b/dev-lang/mono-basic/mono-basic-1.2.6.ebuild
new file mode 100644
index 000000000000..842eb230ff44
--- /dev/null
+++ b/dev-lang/mono-basic/mono-basic-1.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/mono-basic-1.2.6.ebuild,v 1.1 2007/12/14 20:05:36 jurek Exp $
+
+inherit mono multilib
+
+DESCRIPTION="Visual Basic .NET Runtime and Class Libraries"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/mono-${PV}*"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s|\(mono_libdir=\${exec_prefix}\)/lib|\1/$(get_libdir)|" \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}