summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-06-17 06:00:38 +0000
committerKeri Harris <keri@gentoo.org>2006-06-17 06:00:38 +0000
commit274daae1b6e7684ed53e960f2138099c71b86111 (patch)
tree109e0e9a0acd84d5a4545378dc77ce26fbc1e58c /dev-lang/mercury/files
parentmask kqemu use flag since app-emulation/kqemu isn't keyworded for ppc (diff)
downloadgentoo-2-274daae1b6e7684ed53e960f2138099c71b86111.tar.gz
gentoo-2-274daae1b6e7684ed53e960f2138099c71b86111.tar.bz2
gentoo-2-274daae1b6e7684ed53e960f2138099c71b86111.zip
Enable hlc.par.gc libgrade on a minimal install if threading is enabled.
(Portage version: 2.1)
Diffstat (limited to 'dev-lang/mercury/files')
-rw-r--r--dev-lang/mercury/files/mercury-0.12.2-portage-r2.patch119
1 files changed, 119 insertions, 0 deletions
diff --git a/dev-lang/mercury/files/mercury-0.12.2-portage-r2.patch b/dev-lang/mercury/files/mercury-0.12.2-portage-r2.patch
new file mode 100644
index 000000000000..09ea4e596ac4
--- /dev/null
+++ b/dev-lang/mercury/files/mercury-0.12.2-portage-r2.patch
@@ -0,0 +1,119 @@
+--- mercury-compiler-0.12.2.orig/Makefile 2004-11-01 17:46:18.000000000 +1300
++++ mercury-compiler-0.12.2/Makefile 2006-03-18 12:54:23.000000000 +1300
+@@ -26,7 +26,7 @@
+
+ .PHONY: all
+ all:
+- $(MMAKE) MMAKEFLAGS=$(PARALLEL) all 2>&1 | tee make_all.log
++ $(MMAKE) MMAKEFLAGS=$(PARALLEL) all 2>&1 || exit 1
+
+ .PHONY: libmmc
+ libmmc:
+@@ -34,7 +34,7 @@
+
+ .PHONY: install
+ install:
+- $(MMAKE) MMAKEFLAGS=$(PARALLEL) install 2>&1 | tee make_install.log
++ $(MMAKE) MMAKEFLAGS=$(PARALLEL) install 2>&1 || exit 1
+
+ # `mmake clean' has a different meaning to the usual GNU standard `make clean':
+ # it removes the .c files, which makes bootstrapping impossible unless you
+--- mercury-compiler-0.12.2.orig/Mmakefile 2005-01-28 20:11:29.000000000 +1300
++++ mercury-compiler-0.12.2/Mmakefile 2006-06-14 21:14:22.000000000 +1200
+@@ -429,28 +429,13 @@
+ @echo
+ @echo "-- Installation complete."
+ @echo
+- @echo "-- Don't forget to add $(INSTALL_BINDIR) to your PATH,"
+- @echo "-- $(INSTALL_MAN_DIR) to your MANPATH,"
+- @echo "-- and $(INSTALL_INFO_DIR) to your INFOPATH,"
+- @if test $(ENABLE_DEEP_PROFILER) != yes || \
+- cmp -s deep_profiler/mdprof_cgi \
+- $(INSTALL_CGI_DIR)/mdprof_cgi; \
+- then true ; else \
+- echo "-- to copy deep_profiler/mdprof_cgi" \
+- "to $(INSTALL_CGI_DIR),"; \
+- fi
+- @echo "-- and to add the following lines to the \`.emacs' file"
+- @echo "-- in your home directory:"
+- @echo " (setq load-path (cons (expand-file-name "
+- @echo " \"$(INSTALL_ELISP_DIR)\") load-path))"
+- @echo " (autoload 'mdb \"gud\" \"Invoke the Mercury debugger\" t)"
+
+ .PHONY: install_main
+ install_main: all \
+ install_scripts install_util install_runtime install_boehm_gc \
+ install_library install_mdbcomp install_browser install_trace \
+ install_compiler install_profiler install_deep_profiler \
+- install_doc install_config
++ install_doc
+
+ .PHONY: install_scripts
+ install_scripts: scripts
+--- mercury-compiler-0.12.2.orig/configure 2006-01-25 17:24:01.000000000 +1300
++++ mercury-compiler-0.12.2/configure 2006-06-08 19:31:53.000000000 +1200
+@@ -8861,7 +8861,7 @@
+ # Check whether --enable-debug-grades or --disable-debug-grades was given.
+ if test "${enable_debug_grades+set}" = set; then
+ enableval="$enable_debug_grades"
+- enable_debug_grades="enableval"
++ enable_debug_grades="$enableval"
+ else
+ enable_debug_grades=yes
+ fi;
+@@ -8948,7 +8948,6 @@
+ enable_trail_grades=no
+ enable_mm_grades=no
+ enable_hlc_prof_grades=no
+- enable_par_grades=no
+ enable_dotnet_grades=no
+ enable_java_grade=no
+ fi
+--- mercury-compiler-0.12.2.orig/runtime/Mmakefile 2005-12-05 16:34:46.000000000 +1300
++++ mercury-compiler-0.12.2/runtime/Mmakefile 2006-06-14 20:52:31.000000000 +1200
+@@ -390,8 +390,6 @@
+ -[ -d $(INSTALL_MODULE_DIR) ] || mkdir -p $(INSTALL_MODULE_DIR)
+ -[ -d $(INSTALL_MERC_LIB_DIR) ] || mkdir -p $(INSTALL_MERC_LIB_DIR)
+ -[ -d $(INSTALL_CONF_DIR) ] || mkdir -p $(INSTALL_CONF_DIR)
+- -[ -d $(INSTALL_RECONF_DIR)/runtime ] || \
+- mkdir -p $(INSTALL_RECONF_DIR)/runtime
+
+ ifeq ($(findstring java,$(GRADE)),java)
+
+@@ -437,7 +435,6 @@
+ rm -f $(INSTALL_INC_DIR)/mercury_conf.h
+ cp `vpath_find mercury_conf.h` $(INSTALL_CONF_DIR)
+ -chmod u+w $(INSTALL_CONF_DIR)/mercury_conf.h
+- cp `vpath_find mercury_conf.h.in` $(INSTALL_RECONF_DIR)/runtime
+ cp `vpath_find $(MACHHDRS)` $(INSTALL_INC_DIR)/machdeps
+
+ .PHONY: install_init
+--- mercury-compiler-0.12.2.orig/scripts/Mmakefile 2005-01-28 20:11:59.000000000 +1300
++++ mercury-compiler-0.12.2/scripts/Mmakefile 2006-06-14 20:51:21.000000000 +1200
+@@ -16,8 +16,7 @@
+
+ SCRIPTS = mmake mmc mdb c2init mgnuc ml mprof mprof_merge_runs \
+ mtags vpath_find mercury_update_interface \
+- mkfifo_using_mknod mercury_cleanup_install canonical_grade \
+- mercury_config mercury.bat prepare_tmp_dir_fixed_part
++ mercury_cleanup_install canonical_grade
+ DEBUGGER_SCRIPTS = mdbrc xul_tree.xsl
+ EMACS_SCRIPTS = gud.el
+
+@@ -58,8 +57,6 @@
+ [ -d $(INSTALL_LIBDIR)/mdb ] || mkdir -p $(INSTALL_LIBDIR)/mdb
+ [ -d $(INSTALL_CONF_DIR) ] || mkdir -p $(INSTALL_CONF_DIR)
+ [ -d $(INSTALL_ELISP_DIR) ] || mkdir -p $(INSTALL_ELISP_DIR)
+- [ -d $(INSTALL_RECONF_DIR)/scripts ] || \
+- mkdir -p $(INSTALL_RECONF_DIR)/scripts
+
+ .PHONY: install_mmake
+ install_mmake: Mmake.vars Mmake.rules install_dirs
+@@ -77,7 +74,6 @@
+ -for file in $(SCRIPTS); do \
+ chmod u+w $(INSTALL_BINDIR)/$$file ;\
+ done
+- cp *.in *.sh-subr $(SCRIPTS) $(INSTALL_RECONF_DIR)/scripts
+ -rm -f $(INSTALL_BINDIR)/mmake.old
+
+ .PHONY: install_config