summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-12-20 00:13:09 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-12-20 00:13:09 +0000
commit7fbb0c2f8cc88e5bdd7b986f12ef381191525e50 (patch)
tree6a88f07d7bcfa8bb2f247a56ac9ddc8e10f9abf4 /dev-lang/lua
parentAdded a pic patch to use -fPIC flag correctly. This fix hppa compilation. (diff)
downloadgentoo-2-7fbb0c2f8cc88e5bdd7b986f12ef381191525e50.tar.gz
gentoo-2-7fbb0c2f8cc88e5bdd7b986f12ef381191525e50.tar.bz2
gentoo-2-7fbb0c2f8cc88e5bdd7b986f12ef381191525e50.zip
Added a pic patch to use -fPIC flag correctly. This fix hppa compilation.
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/ChangeLog6
-rw-r--r--dev-lang/lua/Manifest4
-rw-r--r--dev-lang/lua/files/lua-5.0.1-pic.patch38
-rw-r--r--dev-lang/lua/lua-5.0.1_beta20031003.ebuild15
4 files changed, 57 insertions, 6 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index ae8d34824428..049f17f048f3 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.11 2003/11/21 20:40:15 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.12 2003/12/20 00:12:53 gmsoft Exp $
*lua-5.0.1_beta20031003 (21 Nov 2003)
+ 20 Dec 2003; Guy Martin <gmsoft@gentoo.org> lua-5.0.1_beta20031003.ebuild,
+ files/lua-5.0.1-pic.patch :
+ Added a pic patch to use -fPIC flag correctly. This fix hppa compilation.
+
21 Nov 2003; Tom Payne <twp@gentoo.org> lua-5.0.1_beta20031003.ebuild :
Version bump using patches from http://lua-users.org/lists/lua-l/2003-10/msg00039.html.
Marked ~x86.
diff --git a/dev-lang/lua/Manifest b/dev-lang/lua/Manifest
index e2a2c88600c6..58071b978271 100644
--- a/dev-lang/lua/Manifest
+++ b/dev-lang/lua/Manifest
@@ -1,7 +1,7 @@
-MD5 450c4c075f659360011e8673d464c79c ChangeLog 1847
+MD5 186a59a0e542e94d57f3cb0f3bee19f7 ChangeLog 1850
MD5 85a5eb8f8b7221914e902987d0cab50b lua-4.0.1.ebuild 741
MD5 77423167968c443c7977b7aa6fabe21f lua-4.0.ebuild 730
-MD5 f631576cccabc1ab777279b640cb2ab6 lua-5.0.1_beta20031003.ebuild 1350
+MD5 e7f1fcb156df4331b269e0cffce38e72 lua-5.0.1_beta20031003.ebuild 1353
MD5 f1d4d3d77ecbb61e83996fcf49225bdd lua-5.0.ebuild 1052
MD5 5b5c840855f0b8c00be987b30fcbf792 lua-5.0_beta.ebuild 1004
MD5 7bb76903226a11484013e9657e217025 files/digest-lua-4.0 55
diff --git a/dev-lang/lua/files/lua-5.0.1-pic.patch b/dev-lang/lua/files/lua-5.0.1-pic.patch
new file mode 100644
index 000000000000..1d7aa5cce0b0
--- /dev/null
+++ b/dev-lang/lua/files/lua-5.0.1-pic.patch
@@ -0,0 +1,38 @@
+diff -uNr lua-5.0.1.orig/Makefile lua-5.0.1/Makefile
+--- lua-5.0.1.orig/Makefile 2003-12-19 23:41:25.394200808 +0000
++++ lua-5.0.1/Makefile 2003-12-19 23:42:39.829884864 +0000
+@@ -38,8 +38,8 @@
+
+ # shared libraries (for Linux)
+ so:
+- ld -o lib/liblua.so.$V -shared src/*.o
+- ld -o lib/liblualib.so.$V -shared src/lib/*.o
++ gcc -o lib/liblua.so.$V -shared src/*.o
++ gcc -o lib/liblualib.so.$V -shared src/lib/*.o
+ cd lib; ln -fs liblua.so.$V liblua.so; ln -fs liblualib.so.$V liblualib.so
+
+ # binaries using shared libraries
+diff -uNr lua-5.0.1.orig/src/Makefile lua-5.0.1/src/Makefile
+--- lua-5.0.1.orig/src/Makefile 2003-12-19 23:41:25.374203848 +0000
++++ lua-5.0.1/src/Makefile 2003-12-19 23:42:07.303829576 +0000
+@@ -4,6 +4,8 @@
+
+ include $(LUA)/config
+
++CFLAGS= $(MYCFLAGS) $(PICFLAGS) $(WARN) $(INCS) $(DEFS)
++
+ OBJS= \
+ lapi.o \
+ lcode.o \
+diff -uNr lua-5.0.1.orig/src/lib/Makefile lua-5.0.1/src/lib/Makefile
+--- lua-5.0.1.orig/src/lib/Makefile 2003-12-19 23:41:25.368204760 +0000
++++ lua-5.0.1/src/lib/Makefile 2003-12-19 23:42:22.414532400 +0000
+@@ -4,6 +4,8 @@
+
+ include $(LUA)/config
+
++CFLAGS= $(MYCFLAGS) $(PICFLAGS) $(WARN) $(INCS) $(DEFS)
++
+ EXTRA_DEFS= $(POPEN) $(TMPNAM) $(DEGREES) $(LOADLIB)
+
+ OBJS= lauxlib.o lbaselib.o ldblib.o liolib.o lmathlib.o ltablib.o lstrlib.o loadlib.o
diff --git a/dev-lang/lua/lua-5.0.1_beta20031003.ebuild b/dev-lang/lua/lua-5.0.1_beta20031003.ebuild
index fd6a6aa7f982..acfb7931408b 100644
--- a/dev-lang/lua/lua-5.0.1_beta20031003.ebuild
+++ b/dev-lang/lua/lua-5.0.1_beta20031003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.1_beta20031003.ebuild,v 1.1 2003/11/21 20:40:15 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.1_beta20031003.ebuild,v 1.2 2003/12/20 00:12:53 gmsoft Exp $
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
@@ -17,15 +17,24 @@ src_unpack() {
unpack lua-5.0.tar.gz || die
mv lua-5.0 lua-5.0.1 || die
unpack lua-5.0-update.tar.gz || die
-}
-src_compile() {
+ cd "${S}"
+
+ epatch "${FILESDIR}/lua-5.0.1-pic.patch"
+
sed -i \
-e 's:^#POPEN= -DUSE_POPEN$:POPEN= -DUSE_POPEN:' \
-e "s:^MYCFLAGS= -O2:MYCFLAGS= ${CFLAGS}:" \
-e 's:INSTALL_ROOT= /usr/local:INSTALL_ROOT= $(DESTDIR)/usr:' \
-e 's:INSTALL_MAN= $(INSTALL_ROOT)/man/man1:INSTALL_MAN= $(INSTALL_ROOT)/share/man/man1:' \
config || die "sed config failed"
+
+}
+
+src_compile() {
+
+ export PICFLAGS=-fPIC
+
emake || die "emake failed"
emake so || die "emake so failed"
}