summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2006-12-07 03:59:47 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2006-12-07 03:59:47 +0000
commitd6002643219d24c6551a4480f93feff9515618e1 (patch)
tree3e065e68edeba74927728934279885b65c662100 /dev-lang/gnu-smalltalk
parentFixed quotations in ChangeLog entry (diff)
downloadgentoo-2-d6002643219d24c6551a4480f93feff9515618e1.tar.gz
gentoo-2-d6002643219d24c6551a4480f93feff9515618e1.tar.bz2
gentoo-2-d6002643219d24c6551a4480f93feff9515618e1.zip
updating gst version
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog7
-rw-r--r--dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.33
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.ebuild75
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 932e9d42e5b3..c13f1df99049 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.20 2006/12/01 10:38:55 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.21 2006/12/07 03:59:47 araujo Exp $
+
+*gnu-smalltalk-2.3 (07 Dec 2006)
+
+ 07 Dec 2006; Luis F. Araujo <araujo@gentoo.org> +gnu-smalltalk-2.3.ebuild:
+ Updated gnu-smalltalk version
01 Dec 2006; Luis F. Araujo <araujo@gentoo.org>
gnu-smalltalk-2.1.12.ebuild, gnu-smalltalk-2.2-r1.ebuild:
diff --git a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.3 b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.3
new file mode 100644
index 000000000000..a7a7026dec71
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.3
@@ -0,0 +1,3 @@
+MD5 a75165ba9f0f50e24fa2160848e12269 smalltalk-2.3.tar.gz 4307332
+RMD160 242fb43396610ad757fc34e97324e845b91fc7e8 smalltalk-2.3.tar.gz 4307332
+SHA256 99ca9188eb24b37830985432448b45ea221d8e69754e50128415103fdd0eb4dd smalltalk-2.3.tar.gz 4307332
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.ebuild
new file mode 100644
index 000000000000..0293d4789915
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.ebuild,v 1.1 2006/12/07 03:59:47 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://www.gnu.org/software/smalltalk/smalltalk.html"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~sparc ~x86 ~amd64"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S=${WORKDIR}/smalltalk-${PV}
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ sed -i "s:\$(DESTDIR)\$(bindir)/gst \$\$srcdir/Finish.st \-VisqS \-a \"\$(DESTDIR)\" \$(MODULES): :" ${S}/Makefile.am
+ sed -i "s:\$(DESTDIR)\$(bindir)/gst \$\$srcdir/Finish.st \-VisqS \-a \"\$(DESTDIR)\" \$(MODULES): :" ${S}/Makefile.in
+ # Fix gst-{load, sunit, reload} script paths.
+ sed -i "s: @bindir@:/usr/bin:" ${S}/scripts/Reload.st ${S}/scripts/Load.st ${S}/scripts/Test.st
+}
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_with tk tcl=/usr/lib` \
+ `use_with tk tk=/usr/lib` \
+ `use_enable gtk gtk` \
+ || die
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info \
+ lispdir=${D}/usr/share/emacs/site-lisp/gnu-smalltalk install \
+ || die
+ rm -rf ${D}/usr/include/sigsegv.h \
+ ${D}/usr/include/snprintfv \
+ ${D}/usr/share/aclocal/snprintfv.m4
+ dodoc AUTHORS COPYING* ChangeLog NEWS PATCHES README THANKS TODO
+ rm -rf ${D}/var
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ einfo "We generate a GNU SmallTalk Image with the right image kernel path."
+ cd /usr/share/smalltalk/
+ /usr/bin/gst -iQ /dev/null
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}