summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:32:26 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:32:26 +0000
commit9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77 (patch)
tree81238fa5a0387a31287aff8608634f53e2b061d8 /dev-lang/gforth/gforth-0.6.2.ebuild
parentadd inherit eutils (diff)
downloadgentoo-2-9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77.tar.gz
gentoo-2-9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77.tar.bz2
gentoo-2-9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77.zip
add inherit eutils
Diffstat (limited to 'dev-lang/gforth/gforth-0.6.2.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.6.2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-lang/gforth/gforth-0.6.2.ebuild b/dev-lang/gforth/gforth-0.6.2.ebuild
index 8898750f14de..aa1df238113a 100644
--- a/dev-lang/gforth/gforth-0.6.2.ebuild
+++ b/dev-lang/gforth/gforth-0.6.2.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.2 2004/03/14 02:29:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.3 2004/04/16 02:28:06 vapier Exp $
-IUSE="emacs"
-
-inherit elisp-common
+inherit elisp-common eutils
DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
HOMEPAGE="http://www.gnu.org/software/gforth"
@@ -13,6 +11,7 @@ SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth//${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE="emacs"
DEPEND="virtual/glibc
emacs? ( virtual/emacs )"
@@ -30,15 +29,16 @@ src_compile() {
use emacs && emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
}
-src_install () {
- make install libdir=${D}/usr/lib \
+src_install() {
+ make \
+ libdir=${D}/usr/lib \
infodir=${D}/usr/share/info \
mandir=${D}/usr/share/man \
datadir=${D}/usr/share \
bindir=${D}/usr/bin \
install || die
- dodoc AUTHORS BUGS COPYING* ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+ dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
if use emacs; then
elisp-install ${PN} *.el *.elc