summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-22 15:29:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-22 15:29:37 +0000
commit5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2 (patch)
treefb179614689ce97339379a59ddfe21a23714a9c4 /dev-lang/gdl/files
parentAdded ~amd64, move scons to DEPEDN, and removed unecessary numarray dependencies (diff)
downloadgentoo-2-5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2.tar.gz
gentoo-2-5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2.tar.bz2
gentoo-2-5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2.zip
Version bump
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-lang/gdl/files')
-rw-r--r--dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch b/dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch
new file mode 100644
index 000000000000..80227f317992
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch
@@ -0,0 +1,31 @@
+--- configure.in.orig 2008-05-22 15:03:04.000000000 +0000
++++ configure.in 2008-05-22 15:03:19.000000000 +0000
+@@ -482,14 +482,14 @@
+
+ if test "x$with_libproj4" != "xno"; then
+ if test "x$with_libproj4" != "xyes"; then
+- LIBS="$LIBS -L$with_libproj4/lib -lproj4"
++ LIBS="$LIBS -L$with_libproj4/lib -lproj"
+ INCLUDES="$INCLUDES -I$with_libproj4/include"
+ else
+ INCLUDES="$INCLUDES -I/usr/include"
+- LIBS="$LIBS -lproj4"
++ LIBS="$LIBS -lproj"
+ fi
+
+- AC_CHECK_LIB(proj4, pj_init, [AC_DEFINE([USE_LIBPROJ4], [1], [Define if you want to use LIBPROJ4])], [
++ AC_CHECK_LIB(proj, pj_init, [AC_DEFINE([USE_LIBPROJ4], [1], [Define if you want to use LIBPROJ4])], [
+ echo ""
+ echo "Error! LIBPROJ4 is required but was not found"
+ echo " Use --with-libproj4=DIR to specify the LIBPROJ4 directory tree"
+--- src/math_utl.hpp.orig 2008-05-22 15:00:39.000000000 +0000
++++ src/math_utl.hpp 2008-05-22 15:01:46.000000000 +0000
+@@ -42,7 +42,7 @@
+ #define COMPLEX COMPLEX2
+
+ extern "C" {
+-#include "lib_proj.h"
++#include <projects.h>
+ }
+
+ PJ *map_init();