summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-04-18 18:09:05 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-04-18 18:09:05 +0000
commit8d1cafce2502b30d09996a20c46dcbad4fbd7127 (patch)
treeb080e4ef299b11f591813de1dcd7d0f28d3104d3 /dev-lang/cxx
parentinitial import (diff)
downloadgentoo-2-8d1cafce2502b30d09996a20c46dcbad4fbd7127.tar.gz
gentoo-2-8d1cafce2502b30d09996a20c46dcbad4fbd7127.tar.bz2
gentoo-2-8d1cafce2502b30d09996a20c46dcbad4fbd7127.zip
Fixing gpg issues, and tweaking dependencies.
Diffstat (limited to 'dev-lang/cxx')
-rw-r--r--dev-lang/cxx/ChangeLog6
-rw-r--r--dev-lang/cxx/cxx-6.5.9.31-r1.ebuild19
2 files changed, 17 insertions, 8 deletions
diff --git a/dev-lang/cxx/ChangeLog b/dev-lang/cxx/ChangeLog
index c26b39473b0f..0716ce61fe18 100644
--- a/dev-lang/cxx/ChangeLog
+++ b/dev-lang/cxx/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-lang/cxx
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cxx/ChangeLog,v 1.2 2003/04/16 21:51:49 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/cxx/ChangeLog,v 1.3 2003/04/18 18:09:05 taviso Exp $
*cxx-6.5.9.31-r1 (16 Apr 2003)
+ 18 Apr 2003; Tavis Ormandy <taviso@gentoo.org> cxx-6.5.9.31-r1.ebuild:
+ Integrating agriffis' gpg fixes from ccc.
+ Updating dependencies.
+
16 Apr 2003; Tavis Ormandy <taviso@gentoo.org> cxx-6.5.9.31-r1.ebuild:
Permissions on some of the cxx includes were not being updated, now explicitly
changed to root:root when unpacked. version bump.
diff --git a/dev-lang/cxx/cxx-6.5.9.31-r1.ebuild b/dev-lang/cxx/cxx-6.5.9.31-r1.ebuild
index 28e6061d96ec..2428931fcf68 100644
--- a/dev-lang/cxx/cxx-6.5.9.31-r1.ebuild
+++ b/dev-lang/cxx/cxx-6.5.9.31-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cxx/cxx-6.5.9.31-r1.ebuild,v 1.1 2003/04/16 21:51:49 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/cxx/cxx-6.5.9.31-r1.ebuild,v 1.2 2003/04/18 18:09:05 taviso Exp $
#
# Ebuild contributed by Tavis Ormandy <taviso@sdf.lonestar.org>
# and edited by Aron Griffis <agriffis@gentoo.org>
@@ -25,7 +25,9 @@ DEPEND="sys-devel/gcc-config
app-arch/rpm2targz
>=sys-apps/sed-4
app-crypt/gnupg
- >=app-shells/bash-2.05b"
+ >=app-shells/bash-2.05b
+ >=dev-libs/libcpml-5.2.01-r2
+ dev-libs/libots"
RDEPEND="virtual/glibc
dev-libs/libots
@@ -55,11 +57,14 @@ src_unpack() {
# :-NULL safeguards against bash bug.
einfo "Decrypting cxx distribution..."
- gpg --quiet --passphrase-fd 0 --output ${cxx_rpm} \
- --decrypt ${DISTDIR}/${cxx_rpm}.crypt \
- <<< ${CXX_LICENSE_KEY:-NULL} >/dev/null 2>&1 || \
- die "Sorry, your license key doesnt seem to unlock the distribution"
-
+ gpg --quiet \
+ --homedir=${T} --no-permission-warning \
+ --no-mdc-warning \
+ --passphrase-fd 0 \
+ --output ${cxx_rpm} \
+ --decrypt ${DISTDIR}/${cxx_rpm}.crypt \
+ <<< ${CXX_LICENSE_KEY:-NULL}
+
ebegin "Unpacking cxx distribution..."
# This is the same as using rpm2targz then extracting 'cept that
# it's faster, less work, and less hard disk space. rpmoffset is