summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-12-21 07:39:29 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-12-21 07:39:29 +0000
commitd981c097318cbdb9abe16e14599dd7ba59328e34 (patch)
tree2373813643c7699fb8a031250d313d6544c4eb83 /dev-java
parentVersion Bump (diff)
downloadgentoo-2-d981c097318cbdb9abe16e14599dd7ba59328e34.tar.gz
gentoo-2-d981c097318cbdb9abe16e14599dd7ba59328e34.tar.bz2
gentoo-2-d981c097318cbdb9abe16e14599dd7ba59328e34.zip
Version Bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-eclipse-ecj/ChangeLog8
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild49
-rw-r--r--dev-java/ant-eclipse-ecj/files/ecj-3.67
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-java/ant-eclipse-ecj/ChangeLog b/dev-java/ant-eclipse-ecj/ChangeLog
index 7ffaea7cfab7..5093ab1a1237 100644
--- a/dev-java/ant-eclipse-ecj/ChangeLog
+++ b/dev-java/ant-eclipse-ecj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ant-eclipse-ecj
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.22 2010/11/05 19:50:45 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.23 2010/12/21 07:39:29 ali_bush Exp $
+
+*ant-eclipse-ecj-3.6 (21 Dec 2010)
+
+ 21 Dec 2010; Alistair Bush <ali_bush@gentoo.org> +files/ecj-3.6,
+ +ant-eclipse-ecj-3.6.ebuild:
+ Version Bump.
05 Nov 2010; Mark Loeser <halcy0n@gentoo.org>
ant-eclipse-ecj-3.5.2.ebuild:
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild
new file mode 100644
index 000000000000..34197c13ceca
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild,v 1.1 2010/12/21 07:39:29 ali_bush Exp $
+
+inherit java-pkg-2
+
+DMF="R-${PV}-201006080911"
+S="${WORKDIR}"
+
+DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF/.0}/ecjsrc-${PV}.zip"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+SLOT="3.6"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4
+ ~dev-java/eclipse-ecj-${PV}
+ >=dev-java/ant-core-1.7"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p src/org/eclipse/jdt/{core,internal}
+ cp org/eclipse/jdt/core/JDTCompilerAdapter.java \
+ src/org/eclipse/jdt/core || die
+ cp -r org/eclipse/jdt/internal/antadapter \
+ src/org/eclipse/jdt/internal || die
+ rm -fr about* org
+}
+
+src_compile() {
+ cd src
+ java-pkg_filter-compiler jikes
+ ejavac -classpath "$(java-pkg_getjars ant-core,eclipse-ecj-${SLOT})" \
+ $(find org/ -name '*.java') || die "ejavac failed!"
+ find org/ -name '*.class' -o -name '*.properties' | \
+ xargs jar cf "${S}/${PN}.jar" || die "jar failed!"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ insinto /usr/share/java-config-2/compiler
+ newins "${FILESDIR}/compiler-settings-${SLOT}" ecj-${SLOT}
+}
diff --git a/dev-java/ant-eclipse-ecj/files/ecj-3.6 b/dev-java/ant-eclipse-ecj/files/ecj-3.6
new file mode 100644
index 000000000000..a15e7705d7a5
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/files/ecj-3.6
@@ -0,0 +1,7 @@
+JAVAC="/usr/bin/ecj-3.5"
+PACKAGE="=dev-java/ant-eclipse-ecj-3.5*"
+SUPPORTED_TARGET="1.1 1.2 1.3 1.4 1.5 1.6 1.7"
+SUPPORTED_SOURCE="1.3 1.4 1.5 1.6 1.7"
+ANT_BUILD_COMPILER="org.eclipse.jdt.core.JDTCompilerAdapter"
+ANT_BUILD_COMPILER_DEPS="eclipse-ecj-3.5,ant-eclipse-ecj-3.5"
+GENERATION="2"