summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-04-08 16:45:48 +0000
committerRalph Sennhauser <sera@gentoo.org>2013-04-08 16:45:48 +0000
commit9331e3cbc0c33578327ba092bcd1c2f7209137df (patch)
treefd5be55c3ecc242ec598aa6f99a6c9d58d5aa9ea /dev-java
parentNew package containing the Java projects eselect modules formerly in java-con... (diff)
downloadgentoo-2-9331e3cbc0c33578327ba092bcd1c2f7209137df.tar.gz
gentoo-2-9331e3cbc0c33578327ba092bcd1c2f7209137df.tar.bz2
gentoo-2-9331e3cbc0c33578327ba092bcd1c2f7209137df.zip
bug 455798: Use recorded VM dependency for launcher
bug 402315: Don't lock on active VM in presence of virtuals. bug 464608: Make Portage dependency explicit. ROOT support. Gentoo Prefix support. Install man page. Eselect modules and run-java-tool are split-out into separate package eselect-java. Desktop files, icons, env.d and profile.d files as well as revdep-rebuild control file now part of baselayout-java. Fix running tests. (Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 3C5CF75A)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-config/ChangeLog17
-rw-r--r--dev-java/java-config/java-config-2.2.0.ebuild29
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-java/java-config/ChangeLog b/dev-java/java-config/ChangeLog
index bc5e72bc0b70..e3758ac54316 100644
--- a/dev-java/java-config/ChangeLog
+++ b/dev-java/java-config/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for dev-java/java-config
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.278 2013/04/06 10:21:50 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.279 2013/04/08 16:45:48 sera Exp $
+
+*java-config-2.2.0 (08 Apr 2013)
+
+ 08 Apr 2013; Ralph Sennhauser <sera@gentoo.org> +java-config-2.2.0.ebuild:
+ bug 455798: Use recorded VM dependency for launcher
+ bug 402315: Don't lock on active VM in presence of virtuals.
+ bug 464608: Make Portage dependency explicit.
+ ROOT support.
+ Gentoo Prefix support.
+ Install man page.
+ Eselect modules and run-java-tool are split-out into separate package
+ eselect-java.
+ Desktop files, icons, env.d and profile.d files as well as revdep-rebuild
+ control file now part of baselayout-java.
+ Fix running tests.
06 Apr 2013; Vlastimil Babka <caster@gentoo.org> -java-config-2.1.10.ebuild,
java-config-2.1.11.ebuild, -java-config-2.1.11-r1.ebuild,
diff --git a/dev-java/java-config/java-config-2.2.0.ebuild b/dev-java/java-config/java-config-2.2.0.ebuild
new file mode 100644
index 000000000000..26e773eae176
--- /dev/null
+++ b/dev-java/java-config/java-config-2.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.2.0.ebuild,v 1.1 2013/04/08 16:45:48 sera Exp $
+
+EAPI="5"
+
+# jython depends on java-config, so don't add it or things will break
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Java environment configuration query tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="http://dev.gentoo.org/~sera/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+# baselayout-java is added as a dep till it can be added to eclass.
+RDEPEND="
+ >=dev-java/java-config-wrapper-0.15
+ sys-apps/baselayout-java
+ sys-apps/portage"
+
+python_test() {
+ esetup.py test || die
+}