summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2006-11-15 04:10:15 +0000
committerWilliam Thomson <wltjr@gentoo.org>2006-11-15 04:10:15 +0000
commit79972ba320d4f709c50e34ad502839c86a7d00e5 (patch)
tree4f6d9fb9ee8581a2cbd94f0ba07eaba8ae5ba9a4 /dev-java
parentadding 0.1.2 to the tree, thanks to pierre for the help in tracking something... (diff)
downloadgentoo-2-79972ba320d4f709c50e34ad502839c86a7d00e5.tar.gz
gentoo-2-79972ba320d4f709c50e34ad502839c86a7d00e5.tar.bz2
gentoo-2-79972ba320d4f709c50e34ad502839c86a7d00e5.zip
Revision bump, moved ebuild from overlay.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-httpclient/ChangeLog8
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild52
-rw-r--r--dev-java/commons-httpclient/files/digest-commons-httpclient-3.0.13
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-java/commons-httpclient/ChangeLog b/dev-java/commons-httpclient/ChangeLog
index 09b41dd80f85..df39124937d2 100644
--- a/dev-java/commons-httpclient/ChangeLog
+++ b/dev-java/commons-httpclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-httpclient
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.30 2006/10/05 15:26:38 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.31 2006/11/15 04:10:15 wltjr Exp $
+
+*commons-httpclient-3.0.1 (15 Nov 2006)
+
+ 15 Nov 2006; William L. Thomson Jr. <wltjr@gentoo.org>
+ +commons-httpclient-3.0.1.ebuild:
+ Revision bump, moved ebuild from overlay.
05 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org>
commons-httpclient-2.0.1.ebuild, commons-httpclient-2.0.2.ebuild,
diff --git a/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild b/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild
new file mode 100644
index 000000000000..6aa277ea81e1
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild,v 1.1 2006/11/15 04:10:15 wltjr Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P=${P/_/-}
+DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
+HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
+SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${MY_P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples source"
+
+RDEPEND=">=virtual/jre-1.3
+ dev-java/commons-logging
+ dev-java/commons-codec"
+
+DEPEND=">=virtual/jdk-1.3
+ sys-apps/sed
+ >=dev-java/ant-core-1.4
+ junit? ( dev-java/junit )
+ source? ( app-arch/zip )
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ mkdir lib && cd lib
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from commons-codec
+}
+
+src_compile() {
+ eant dist $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar dist/${PN}-contrib.jar
+ use doc && java-pkg_dohtml -r dist/docs/*
+ use source && java-pkg_dosrc src/java/* src/contrib/*
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r src/examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-java/commons-httpclient/files/digest-commons-httpclient-3.0.1 b/dev-java/commons-httpclient/files/digest-commons-httpclient-3.0.1
new file mode 100644
index 000000000000..9c059eca7220
--- /dev/null
+++ b/dev-java/commons-httpclient/files/digest-commons-httpclient-3.0.1
@@ -0,0 +1,3 @@
+MD5 abe79c67448079e0deb6a49530f993e2 commons-httpclient-3.0.1-src.tar.gz 1698379
+RMD160 5b02f6731718a590dbace90e6e494a9568a7abdb commons-httpclient-3.0.1-src.tar.gz 1698379
+SHA256 6a26b4dfb9bfacf9849793d6edf997079b2230e5523f7aa9274a7d1d2fb1f2a8 commons-httpclient-3.0.1-src.tar.gz 1698379