summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-08-10 04:18:52 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-08-10 04:18:52 +0000
commit5a47f9ebf5453f697265b3f1891e1d92a54e1a38 (patch)
tree76f8213851fe272be7ba4c976628ab0c65c54cc6 /dev-java
parentStable x86; another game to try and avoid (diff)
downloadgentoo-2-5a47f9ebf5453f697265b3f1891e1d92a54e1a38.tar.gz
gentoo-2-5a47f9ebf5453f697265b3f1891e1d92a54e1a38.tar.bz2
gentoo-2-5a47f9ebf5453f697265b3f1891e1d92a54e1a38.zip
Migrated to the new Java system by nathanegge@yahoo.com, bug #143285
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/oscache/ChangeLog9
-rw-r--r--dev-java/oscache/files/digest-oscache-2.0.22
-rw-r--r--dev-java/oscache/files/digest-oscache-2.0.2-r13
-rw-r--r--dev-java/oscache/oscache-2.0.2-r1.ebuild69
4 files changed, 81 insertions, 2 deletions
diff --git a/dev-java/oscache/ChangeLog b/dev-java/oscache/ChangeLog
index a9606d759569..e42cd1491f31 100644
--- a/dev-java/oscache/ChangeLog
+++ b/dev-java/oscache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/oscache
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/ChangeLog,v 1.4 2005/10/15 13:19:25 axxo Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/ChangeLog,v 1.5 2006/08/10 04:18:52 nichoj Exp $
+
+*oscache-2.0.2-r1 (10 Aug 2006)
+
+ 10 Aug 2006; Joshua Nichols <nichoj@gentoo.org> +oscache-2.0.2-r1.ebuild:
+ Migrated to the new Java system by nathanegge@yahoo.com, bug #143285
15 Oct 2005; Thomas Matthijs <axxo@gentoo.org> oscache-2.0.2.ebuild:
move dev-java/jms dev-java/sun-jms
diff --git a/dev-java/oscache/files/digest-oscache-2.0.2 b/dev-java/oscache/files/digest-oscache-2.0.2
index 5b905b4bd986..595664bab683 100644
--- a/dev-java/oscache/files/digest-oscache-2.0.2
+++ b/dev-java/oscache/files/digest-oscache-2.0.2
@@ -1 +1,3 @@
MD5 0f724f71a998c8be3bbeb1eb2d1fa783 oscache-2.0.2-full.zip 2533146
+RMD160 cd30ef95ce493d3b4b9f3809292e39d108115891 oscache-2.0.2-full.zip 2533146
+SHA256 d909d10aec024d9f53475030843afbb3c3bd18ee1a77b3e9e486a6f0fb336d52 oscache-2.0.2-full.zip 2533146
diff --git a/dev-java/oscache/files/digest-oscache-2.0.2-r1 b/dev-java/oscache/files/digest-oscache-2.0.2-r1
new file mode 100644
index 000000000000..595664bab683
--- /dev/null
+++ b/dev-java/oscache/files/digest-oscache-2.0.2-r1
@@ -0,0 +1,3 @@
+MD5 0f724f71a998c8be3bbeb1eb2d1fa783 oscache-2.0.2-full.zip 2533146
+RMD160 cd30ef95ce493d3b4b9f3809292e39d108115891 oscache-2.0.2-full.zip 2533146
+SHA256 d909d10aec024d9f53475030843afbb3c3bd18ee1a77b3e9e486a6f0fb336d52 oscache-2.0.2-full.zip 2533146
diff --git a/dev-java/oscache/oscache-2.0.2-r1.ebuild b/dev-java/oscache/oscache-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..02df78350ad5
--- /dev/null
+++ b/dev-java/oscache/oscache-2.0.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/oscache-2.0.2-r1.ebuild,v 1.1 2006/08/10 04:18:52 nichoj Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="OSCache is a widely used, high performance J2EE caching framework."
+SRC_URI="https://oscache.dev.java.net/files/documents/629/2653/${P}-full.zip"
+HOMEPAGE="http://www.opensymphony.com/oscache/"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+COMMON_DEP="
+ dev-java/commons-collections
+ dev-java/commons-logging
+ =dev-java/servletapi-2.3*
+ dev-java/sun-jms
+ dev-java/jgroups"
+RDEPEND=">=virtual/jre-1.3
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.3
+ ${COMMON_DEP}
+ app-arch/unzip"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ rm *.jar
+}
+
+src_compile() {
+ local build_dir=${S}/build
+ local classpath="-classpath $(java-pkg_getjars commons-logging,commons-collections,servletapi-2.3,sun-jms,jgroups):${build_dir}:."
+ mkdir ${build_dir}
+
+ echo "Building core..."
+ cd ${S}/src/core/java
+ ejavac ${classpath} -nowarn -d ${build_dir} $(find -name "*.java") || die
+
+ echo "Building cluster support plugin..."
+ cd ${S}/src/plugins/clustersupport/java
+ find -name "*.java" -exec sed -i -e "s/org.javagroups/org.jgroups/g" {} \;
+ ejavac ${classpath} -nowarn -d ${build_dir} $(find -name "*.java") || die
+
+ echo "Building disk persistence plugin..."
+ cd ${S}/src/plugins/diskpersistence/java
+ ejavac ${classpath} -nowarn -d ${build_dir} `find -name "*.java"` || die "compile failed"
+
+ if use doc ; then
+ echo "Building documentation..."
+ mkdir ${S}/javadoc
+ cd ${build_dir}
+ local sourcepath="${S}/src/core/java:${S}/src/plugins/diskpersistence/java:${S}/src/plugins/clustersupport/java"
+ javadoc ${classpath} -sourcepath ${sourcepath} -d ${S}/javadoc \
+ $(find com/opensymphony/oscache -type d | tr '/' '.') \
+ || die "failed to create javadoc"
+ fi
+
+ cd ${S}
+ jar cf ${PN}.jar -C build .
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ dodoc readme.txt
+ use doc && java-pkg_dohtml -r javadoc
+}