summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-01-23 10:30:56 +0000
committerRalph Sennhauser <sera@gentoo.org>2013-01-23 10:30:56 +0000
commit1476d0b7c4fcc9ab6a8d0201bfec70afeb75515f (patch)
treebdeb5a584e7377f1cd851d3ea2ae378647b32487 /dev-java
parentsci-visualization/gwyddion: Backport patches which upstream declares importan... (diff)
downloadgentoo-2-1476d0b7c4fcc9ab6a8d0201bfec70afeb75515f.tar.gz
gentoo-2-1476d0b7c4fcc9ab6a8d0201bfec70afeb75515f.tar.bz2
gentoo-2-1476d0b7c4fcc9ab6a8d0201bfec70afeb75515f.zip
Bump and make gcc[gtk] dep optional. #453422
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 3C5CF75A)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/gcj-jdk/ChangeLog10
-rw-r--r--dev-java/gcj-jdk/gcj-jdk-4.5.4-r1.ebuild98
-rw-r--r--dev-java/gcj-jdk/gcj-jdk-4.6.3-r3.ebuild98
-rw-r--r--dev-java/gcj-jdk/gcj-jdk-4.7.2.ebuild98
4 files changed, 303 insertions, 1 deletions
diff --git a/dev-java/gcj-jdk/ChangeLog b/dev-java/gcj-jdk/ChangeLog
index f0e4a32a1923..615135d8ed95 100644
--- a/dev-java/gcj-jdk/ChangeLog
+++ b/dev-java/gcj-jdk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/gcj-jdk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gcj-jdk/ChangeLog,v 1.10 2013/01/13 16:53:02 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gcj-jdk/ChangeLog,v 1.11 2013/01/23 10:30:56 sera Exp $
+
+*gcj-jdk-4.7.2 (23 Jan 2013)
+*gcj-jdk-4.6.3-r3 (23 Jan 2013)
+*gcj-jdk-4.5.4-r1 (23 Jan 2013)
+
+ 23 Jan 2013; Ralph Sennhauser <sera@gentoo.org> +gcj-jdk-4.5.4-r1.ebuild,
+ +gcj-jdk-4.6.3-r3.ebuild, +gcj-jdk-4.7.2.ebuild:
+ Bump and make gcc[gtk] dep optional. #453422
13 Jan 2013; Ralph Sennhauser <sera@gentoo.org> files/gcj-jdk.env:
Make vm env file Prefix aware. #445350
diff --git a/dev-java/gcj-jdk/gcj-jdk-4.5.4-r1.ebuild b/dev-java/gcj-jdk/gcj-jdk-4.5.4-r1.ebuild
new file mode 100644
index 000000000000..4223cf5a4f89
--- /dev/null
+++ b/dev-java/gcj-jdk/gcj-jdk-4.5.4-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gcj-jdk/gcj-jdk-4.5.4-r1.ebuild,v 1.1 2013/01/23 10:30:56 sera Exp $
+
+EAPI="5"
+
+inherit java-vm-2 multilib
+
+DESCRIPTION="Java wrappers around GCJ"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="X"
+
+ECJ_GCJ_SLOT="3.5"
+
+RDEPEND="
+ ~sys-devel/gcc-${PV}[gcj]
+ X? ( ~sys-devel/gcc-${PV}[gtk] )
+ dev-java/ecj-gcj:${ECJ_GCJ_SLOT}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ # jre lib paths ...
+ local libarch="$(get_system_arch)"
+ local gcc_version=${PV}
+ local gccbin=$(gcc-config -B ${gcc_version})
+ gccbin=${gccbin#"${EPREFIX}"}
+ local gcclib=$(gcc-config -L ${gcc_version} | cut -d':' -f1)
+ gcclib=${gcclib#"${EPREFIX}"}
+ local gcjhome="/usr/$(get_libdir)/${P}"
+ local gccchost="${CHOST}"
+ local gcjlibdir=$(echo "${EPREFIX}"/usr/$(get_libdir)/gcj-${gcc_version}-*)
+ gcjlibdir=${gcjlibdir#"${EPREFIX}"}
+
+ # links
+ dodir ${gcjhome}/bin
+ dodir ${gcjhome}/jre/bin
+ dosym ${gccbin}/gij ${gcjhome}/bin/java
+ dosym ${gccbin}/gij ${gcjhome}/jre/bin/java
+ dosym ${gccbin}/gjar ${gcjhome}/bin/jar
+ dosym ${gccbin}/gjdoc ${gcjhome}/bin/javadoc
+ dosym ${gccbin}/grmic ${gcjhome}/bin/rmic
+ dosym ${gccbin}/gjavah ${gcjhome}/bin/javah
+ dosym ${gccbin}/jcf-dump ${gcjhome}/bin/javap
+ dosym ${gccbin}/gappletviewer ${gcjhome}/bin/appletviewer
+ dosym ${gccbin}/gjarsigner ${gcjhome}/bin/jarsigner
+ dosym ${gccbin}/grmiregistry ${gcjhome}/bin/rmiregistry
+ dosym ${gccbin}/grmiregistry ${gcjhome}/jre/bin/rmiregistry
+ dosym ${gccbin}/gkeytool ${gcjhome}/bin/keytool
+ dosym ${gccbin}/gkeytool ${gcjhome}/jre/bin/keytool
+ dosym ${gccbin}/gnative2ascii ${gcjhome}/bin/native2ascii
+ dosym ${gccbin}/gorbd ${gcjhome}/bin/orbd
+ dosym ${gccbin}/gorbd ${gcjhome}/jre/bin/orbd
+ dosym ${gccbin}/grmid ${gcjhome}/bin/rmid
+ dosym ${gccbin}/grmid ${gcjhome}/jre/bin/rmid
+ dosym ${gccbin}/gserialver ${gcjhome}/bin/serialver
+ dosym ${gccbin}/gtnameserv ${gcjhome}/bin/tnameserv
+ dosym ${gccbin}/gtnameserv ${gcjhome}/jre/bin/tnameserv
+
+ dodir ${gcjhome}/jre/lib/${libarch}/client
+ dodir ${gcjhome}/jre/lib/${libarch}/server
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/client/libjvm.so
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/server/libjvm.so
+ use X && dosym ${gcjlibdir}/libjawt.so ${gcjhome}/jre/lib/${libarch}/libjawt.so
+
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-${gcc_version/_/-}.jar \
+ ${gcjhome}/jre/lib/rt.jar
+ dodir ${gcjhome}/lib
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-tools-${gcc_version/_/-}.jar \
+ ${gcjhome}/lib/tools.jar
+ dosym ${gcclib}/include ${gcjhome}
+
+ dosym /usr/bin/ecj-gcj-${ECJ_GCJ_SLOT} ${gcjhome}/bin/javac
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Do not set as system VM (see below)
+ # java-vm-2_pkg_postinst
+
+ ewarn "gcj does not currently provide all the 1.5 APIs."
+ ewarn "See http://builder.classpath.org/japi/libgcj-jdk15.html"
+ ewarn "Check for existing bugs relating to missing APIs and file"
+ ewarn "new ones at http://gcc.gnu.org/bugzilla/"
+ ewarn
+ ewarn "Due to this and limited manpower, we currently cannot support"
+ ewarn "using gcj-jdk as a system VM. Its main purpose is to bootstrap"
+ ewarn "IcedTea without prior binary VM installation. To do that, execute:"
+ ewarn
+ ewarn "emerge -o icedtea && emerge icedtea"
+}
diff --git a/dev-java/gcj-jdk/gcj-jdk-4.6.3-r3.ebuild b/dev-java/gcj-jdk/gcj-jdk-4.6.3-r3.ebuild
new file mode 100644
index 000000000000..4560dc154ae7
--- /dev/null
+++ b/dev-java/gcj-jdk/gcj-jdk-4.6.3-r3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gcj-jdk/gcj-jdk-4.6.3-r3.ebuild,v 1.1 2013/01/23 10:30:56 sera Exp $
+
+EAPI="5"
+
+inherit java-vm-2 multilib
+
+DESCRIPTION="Java wrappers around GCJ"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-linux"
+SLOT="0"
+IUSE="X"
+
+ECJ_GCJ_SLOT="3.6"
+
+RDEPEND="
+ ~sys-devel/gcc-${PV}[gcj]
+ X? ( ~sys-devel/gcc-${PV}[gtk] )
+ dev-java/ecj-gcj:${ECJ_GCJ_SLOT}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ # jre lib paths ...
+ local libarch="$(get_system_arch)"
+ local gcc_version=${PV}
+ local gccbin=$(gcc-config -B ${gcc_version})
+ gccbin=${gccbin#"${EPREFIX}"}
+ local gcclib=$(gcc-config -L ${gcc_version} | cut -d':' -f1)
+ gcclib=${gcclib#"${EPREFIX}"}
+ local gcjhome="/usr/$(get_libdir)/${P}"
+ local gccchost="${CHOST}"
+ local gcjlibdir=$(echo "${EPREFIX}"/usr/$(get_libdir)/gcj-${gcc_version}-*)
+ gcjlibdir=${gcjlibdir#"${EPREFIX}"}
+
+ # links
+ dodir ${gcjhome}/bin
+ dodir ${gcjhome}/jre/bin
+ dosym ${gccbin}/gij ${gcjhome}/bin/java
+ dosym ${gccbin}/gij ${gcjhome}/jre/bin/java
+ dosym ${gccbin}/gjar ${gcjhome}/bin/jar
+ dosym ${gccbin}/gjdoc ${gcjhome}/bin/javadoc
+ dosym ${gccbin}/grmic ${gcjhome}/bin/rmic
+ dosym ${gccbin}/gjavah ${gcjhome}/bin/javah
+ dosym ${gccbin}/jcf-dump ${gcjhome}/bin/javap
+ dosym ${gccbin}/gappletviewer ${gcjhome}/bin/appletviewer
+ dosym ${gccbin}/gjarsigner ${gcjhome}/bin/jarsigner
+ dosym ${gccbin}/grmiregistry ${gcjhome}/bin/rmiregistry
+ dosym ${gccbin}/grmiregistry ${gcjhome}/jre/bin/rmiregistry
+ dosym ${gccbin}/gkeytool ${gcjhome}/bin/keytool
+ dosym ${gccbin}/gkeytool ${gcjhome}/jre/bin/keytool
+ dosym ${gccbin}/gnative2ascii ${gcjhome}/bin/native2ascii
+ dosym ${gccbin}/gorbd ${gcjhome}/bin/orbd
+ dosym ${gccbin}/gorbd ${gcjhome}/jre/bin/orbd
+ dosym ${gccbin}/grmid ${gcjhome}/bin/rmid
+ dosym ${gccbin}/grmid ${gcjhome}/jre/bin/rmid
+ dosym ${gccbin}/gserialver ${gcjhome}/bin/serialver
+ dosym ${gccbin}/gtnameserv ${gcjhome}/bin/tnameserv
+ dosym ${gccbin}/gtnameserv ${gcjhome}/jre/bin/tnameserv
+
+ dodir ${gcjhome}/jre/lib/${libarch}/client
+ dodir ${gcjhome}/jre/lib/${libarch}/server
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/client/libjvm.so
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/server/libjvm.so
+ use X && dosym ${gcjlibdir}/libjawt.so ${gcjhome}/jre/lib/${libarch}/libjawt.so
+
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-${gcc_version/_/-}.jar \
+ ${gcjhome}/jre/lib/rt.jar
+ dodir ${gcjhome}/lib
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-tools-${gcc_version/_/-}.jar \
+ ${gcjhome}/lib/tools.jar
+ dosym ${gcclib}/include ${gcjhome}
+
+ dosym /usr/bin/ecj-gcj-${ECJ_GCJ_SLOT} ${gcjhome}/bin/javac
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Do not set as system VM (see below)
+ # java-vm-2_pkg_postinst
+
+ ewarn "gcj does not currently provide all the 1.5 APIs."
+ ewarn "See http://builder.classpath.org/japi/libgcj-jdk15.html"
+ ewarn "Check for existing bugs relating to missing APIs and file"
+ ewarn "new ones at http://gcc.gnu.org/bugzilla/"
+ ewarn
+ ewarn "Due to this and limited manpower, we currently cannot support"
+ ewarn "using gcj-jdk as a system VM. Its main purpose is to bootstrap"
+ ewarn "IcedTea without prior binary VM installation. To do that, execute:"
+ ewarn
+ ewarn "emerge -o icedtea && emerge icedtea"
+}
diff --git a/dev-java/gcj-jdk/gcj-jdk-4.7.2.ebuild b/dev-java/gcj-jdk/gcj-jdk-4.7.2.ebuild
new file mode 100644
index 000000000000..d9a0efeae3c5
--- /dev/null
+++ b/dev-java/gcj-jdk/gcj-jdk-4.7.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gcj-jdk/gcj-jdk-4.7.2.ebuild,v 1.1 2013/01/23 10:30:56 sera Exp $
+
+EAPI="5"
+
+inherit java-vm-2 multilib
+
+DESCRIPTION="Java wrappers around GCJ"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-linux"
+SLOT="0"
+IUSE="X"
+
+ECJ_GCJ_SLOT="3.6"
+
+RDEPEND="
+ ~sys-devel/gcc-${PV}[gcj]
+ X? ( ~sys-devel/gcc-${PV}[gtk] )
+ dev-java/ecj-gcj:${ECJ_GCJ_SLOT}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ # jre lib paths ...
+ local libarch="$(get_system_arch)"
+ local gcc_version=${PV}
+ local gccbin=$(gcc-config -B ${gcc_version})
+ gccbin=${gccbin#"${EPREFIX}"}
+ local gcclib=$(gcc-config -L ${gcc_version} | cut -d':' -f1)
+ gcclib=${gcclib#"${EPREFIX}"}
+ local gcjhome="/usr/$(get_libdir)/${P}"
+ local gccchost="${CHOST}"
+ local gcjlibdir=$(echo "${EPREFIX}"/usr/$(get_libdir)/gcj-${gcc_version}-*)
+ gcjlibdir=${gcjlibdir#"${EPREFIX}"}
+
+ # links
+ dodir ${gcjhome}/bin
+ dodir ${gcjhome}/jre/bin
+ dosym ${gccbin}/gij ${gcjhome}/bin/java
+ dosym ${gccbin}/gij ${gcjhome}/jre/bin/java
+ dosym ${gccbin}/gjar ${gcjhome}/bin/jar
+ dosym ${gccbin}/gjdoc ${gcjhome}/bin/javadoc
+ dosym ${gccbin}/grmic ${gcjhome}/bin/rmic
+ dosym ${gccbin}/gjavah ${gcjhome}/bin/javah
+ dosym ${gccbin}/jcf-dump ${gcjhome}/bin/javap
+ dosym ${gccbin}/gappletviewer ${gcjhome}/bin/appletviewer
+ dosym ${gccbin}/gjarsigner ${gcjhome}/bin/jarsigner
+ dosym ${gccbin}/grmiregistry ${gcjhome}/bin/rmiregistry
+ dosym ${gccbin}/grmiregistry ${gcjhome}/jre/bin/rmiregistry
+ dosym ${gccbin}/gkeytool ${gcjhome}/bin/keytool
+ dosym ${gccbin}/gkeytool ${gcjhome}/jre/bin/keytool
+ dosym ${gccbin}/gnative2ascii ${gcjhome}/bin/native2ascii
+ dosym ${gccbin}/gorbd ${gcjhome}/bin/orbd
+ dosym ${gccbin}/gorbd ${gcjhome}/jre/bin/orbd
+ dosym ${gccbin}/grmid ${gcjhome}/bin/rmid
+ dosym ${gccbin}/grmid ${gcjhome}/jre/bin/rmid
+ dosym ${gccbin}/gserialver ${gcjhome}/bin/serialver
+ dosym ${gccbin}/gtnameserv ${gcjhome}/bin/tnameserv
+ dosym ${gccbin}/gtnameserv ${gcjhome}/jre/bin/tnameserv
+
+ dodir ${gcjhome}/jre/lib/${libarch}/client
+ dodir ${gcjhome}/jre/lib/${libarch}/server
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/client/libjvm.so
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/server/libjvm.so
+ use X && dosym ${gcjlibdir}/libjawt.so ${gcjhome}/jre/lib/${libarch}/libjawt.so
+
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-${gcc_version/_/-}.jar \
+ ${gcjhome}/jre/lib/rt.jar
+ dodir ${gcjhome}/lib
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-tools-${gcc_version/_/-}.jar \
+ ${gcjhome}/lib/tools.jar
+ dosym ${gcclib}/include ${gcjhome}
+
+ dosym /usr/bin/ecj-gcj-${ECJ_GCJ_SLOT} ${gcjhome}/bin/javac
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Do not set as system VM (see below)
+ # java-vm-2_pkg_postinst
+
+ ewarn "gcj does not currently provide all the 1.5 APIs."
+ ewarn "See http://builder.classpath.org/japi/libgcj-jdk15.html"
+ ewarn "Check for existing bugs relating to missing APIs and file"
+ ewarn "new ones at http://gcc.gnu.org/bugzilla/"
+ ewarn
+ ewarn "Due to this and limited manpower, we currently cannot support"
+ ewarn "using gcj-jdk as a system VM. Its main purpose is to bootstrap"
+ ewarn "IcedTea without prior binary VM installation. To do that, execute:"
+ ewarn
+ ewarn "emerge -o icedtea && emerge icedtea"
+}