summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-08 05:19:47 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-08 05:19:47 +0000
commitfc892d69136fecbce71f711208a2a3bad0ae9d22 (patch)
treeb3f60817af60333aa6e9d41775c15b3d36b1f4bf /dev-java/werken-xpath
parentVersion bump to fix a bunch of bugs. (diff)
downloadgentoo-2-fc892d69136fecbce71f711208a2a3bad0ae9d22.tar.gz
gentoo-2-fc892d69136fecbce71f711208a2a3bad0ae9d22.tar.bz2
gentoo-2-fc892d69136fecbce71f711208a2a3bad0ae9d22.zip
Initial commit. Needed for bug #63275.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-java/werken-xpath')
-rw-r--r--dev-java/werken-xpath/ChangeLog14
-rw-r--r--dev-java/werken-xpath/Manifest6
-rw-r--r--dev-java/werken-xpath/files/digest-werken-xpath-0.9.4_beta1
-rw-r--r--dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-gentoo.patch35
-rw-r--r--dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-compile.patch24
-rw-r--r--dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-jdom.patch86
-rw-r--r--dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-tests.patch10
-rw-r--r--dev-java/werken-xpath/metadata.xml5
-rw-r--r--dev-java/werken-xpath/werken-xpath-0.9.4_beta.ebuild61
9 files changed, 242 insertions, 0 deletions
diff --git a/dev-java/werken-xpath/ChangeLog b/dev-java/werken-xpath/ChangeLog
new file mode 100644
index 000000000000..391724844eab
--- /dev/null
+++ b/dev-java/werken-xpath/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-java/werken-xpath
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/werken-xpath/ChangeLog,v 1.1 2005/12/08 05:19:47 nichoj Exp $
+
+*werken-xpath-0.9.4_beta (08 Dec 2005)
+
+ 08 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ +files/werken-xpath-0.9.4_beta-gentoo.patch,
+ +files/werken-xpath-0.9.4_beta-jpp-compile.patch,
+ +files/werken-xpath-0.9.4_beta-jpp-jdom.patch,
+ +files/werken-xpath-0.9.4_beta-jpp-tests.patch, +metadata.xml,
+ +werken-xpath-0.9.4_beta.ebuild:
+ Initial commit. Needed for bug #63275.
+
diff --git a/dev-java/werken-xpath/Manifest b/dev-java/werken-xpath/Manifest
new file mode 100644
index 000000000000..1028d7a0c04d
--- /dev/null
+++ b/dev-java/werken-xpath/Manifest
@@ -0,0 +1,6 @@
+MD5 78da4f7f73f91c6bd92eedf1fbefaab6 files/digest-werken-xpath-0.9.4_beta 80
+MD5 4185b96fdb3a49d1eb6cdb93057e440b files/werken-xpath-0.9.4_beta-gentoo.patch 1313
+MD5 28584ccbd78d4037e8b242d825e03f33 files/werken-xpath-0.9.4_beta-jpp-compile.patch 1189
+MD5 e2a3cd20c9fb62710b171d6b9e179061 files/werken-xpath-0.9.4_beta-jpp-jdom.patch 3606
+MD5 72e762a216369d14fcf180a0229e03a5 files/werken-xpath-0.9.4_beta-jpp-tests.patch 353
+MD5 85b813eb26cbdd9df49a4c92d9ef87bc werken-xpath-0.9.4_beta.ebuild 1479
diff --git a/dev-java/werken-xpath/files/digest-werken-xpath-0.9.4_beta b/dev-java/werken-xpath/files/digest-werken-xpath-0.9.4_beta
new file mode 100644
index 000000000000..99f0b3aaf949
--- /dev/null
+++ b/dev-java/werken-xpath/files/digest-werken-xpath-0.9.4_beta
@@ -0,0 +1 @@
+MD5 966840130d5eed4fcab962d89be91ff1 werken.xpath-0.9.4-beta-src.tar.gz 1652916
diff --git a/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-gentoo.patch b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-gentoo.patch
new file mode 100644
index 000000000000..1cd61fc818ad
--- /dev/null
+++ b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-gentoo.patch
@@ -0,0 +1,35 @@
+diff -ru werken.xpath/build.xml werken.xpath-patched/build.xml
+--- werken.xpath/build.xml 2000-11-19 21:45:16.000000000 -0500
++++ werken.xpath-patched/build.xml 2005-07-14 21:14:01.000000000 -0400
+@@ -49,6 +49,9 @@
+ <!-- JDK1.1 collections -->
+ <property name="coll.import" value="com.sun.java.util.collections"/>
+ <available classname="${coll.import}.Collection" property="coll.present"/>
++ <path id="lib.classpath">
++ <fileset dir="${lib.dir}" includes="**/*.jar"/>
++ </path>
+ </target>
+
+ <!-- =================================================================== -->
+@@ -174,7 +177,8 @@
+ <javac srcdir="${build.src}"
+ destdir="${build.dest}"
+ debug="${debug}"
+- optimize="${optimize}">
++ optimize="${optimize}"
++ classpathref="lib.classpath">
+ </javac>
+ </target>
+
+diff -ru werken.xpath/src/com/werken/xpath/Test.java werken.xpath-patched/src/com/werken/xpath/Test.java
+--- werken.xpath/src/com/werken/xpath/Test.java 2000-10-23 23:45:32.000000000 -0400
++++ werken.xpath-patched/src/com/werken/xpath/Test.java 2005-07-14 21:22:42.000000000 -0400
+@@ -57,7 +57,7 @@
+ System.err.println("Results :: " + results);
+
+ }
+- catch (JDOMException jde)
++ catch (Exception jde)
+ {
+ jde.printStackTrace(System.err);
+ }
diff --git a/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-compile.patch b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-compile.patch
new file mode 100644
index 000000000000..516158f63083
--- /dev/null
+++ b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-compile.patch
@@ -0,0 +1,24 @@
+diff -Nru werken.xpath.orig/src/com/werken/xpath/impl/Op.java werken.xpath/src/com/werken/xpath/impl/Op.java
+--- werken.xpath.orig/src/com/werken/xpath/impl/Op.java 2000-08-27 03:16:03.000000000 +0300
++++ werken.xpath/src/com/werken/xpath/impl/Op.java 2003-03-02 01:44:52.000000000 +0200
+@@ -19,7 +19,7 @@
+ public final static Op GT = new Op(">");
+ public final static Op LT_EQUAL = new Op("<=");
+ public final static Op GT_EQUAL = new Op(">=");
+- public final static Op MOD = new Op("%");;
++ public final static Op MOD = new Op("%");
+ public final static Op DIV = new Op("/");
+ public final static Op PLUS = new Op("+");
+ public final static Op MINUS = new Op("-");
+diff -Nru werken.xpath.orig/src/com/werken/xpath/impl/UnAbbrStep.java werken.xpath/src/com/werken/xpath/impl/UnAbbrStep.java
+--- werken.xpath.orig/src/com/werken/xpath/impl/UnAbbrStep.java 2000-10-31 22:20:56.000000000 +0200
++++ werken.xpath/src/com/werken/xpath/impl/UnAbbrStep.java 2003-03-02 01:45:04.000000000 +0200
+@@ -175,7 +175,7 @@
+ }
+ }
+
+- return aggregateResults;;
++ return aggregateResults;
+ }
+
+ private List applyPredicates(List nodeSet,
diff --git a/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-jdom.patch b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-jdom.patch
new file mode 100644
index 000000000000..ba2b268f1c89
--- /dev/null
+++ b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-jdom.patch
@@ -0,0 +1,86 @@
+diff -Nru werken.xpath.orig/src/com/werken/xpath/function/StringFunction.java werken.xpath/src/com/werken/xpath/function/StringFunction.java
+--- werken.xpath.orig/src/com/werken/xpath/function/StringFunction.java 2000-10-24 06:30:00.000000000 +0300
++++ werken.xpath/src/com/werken/xpath/function/StringFunction.java 2003-03-02 01:56:03.000000000 +0200
+@@ -71,7 +71,7 @@
+
+ public static String evaluate(Element elem)
+ {
+- List content = elem.getMixedContent();
++ List content = elem.getContent();
+
+ Iterator contentIter = content.iterator();
+ Object each = null;
+diff -Nru werken.xpath.orig/src/com/werken/xpath/impl/NodeTypeStep.java werken.xpath/src/com/werken/xpath/impl/NodeTypeStep.java
+--- werken.xpath.orig/src/com/werken/xpath/impl/NodeTypeStep.java 2000-10-26 04:09:41.000000000 +0300
++++ werken.xpath/src/com/werken/xpath/impl/NodeTypeStep.java 2003-03-02 01:56:03.000000000 +0200
+@@ -84,16 +84,16 @@
+ {
+ if ( isAbsolute() )
+ {
+- results.addAll( applyToNodes( ((Element)node).getDocument().getMixedContent() ) );
++ results.addAll( applyToNodes( ((Element)node).getDocument().getContent() ) );
+ }
+ else
+ {
+- results.addAll( applyToNodes( ((Element)node).getMixedContent() ) );
++ results.addAll( applyToNodes( ((Element)node).getContent() ) );
+ }
+ }
+ else if ( node instanceof Document )
+ {
+- results.addAll( applyToNodes( ((Document)node).getMixedContent() ) );
++ results.addAll( applyToNodes( ((Document)node).getContent() ) );
+ }
+
+ return results;
+diff -Nru werken.xpath.orig/src/com/werken/xpath/impl/UnAbbrStep.java werken.xpath/src/com/werken/xpath/impl/UnAbbrStep.java
+--- werken.xpath.orig/src/com/werken/xpath/impl/UnAbbrStep.java 2000-10-31 22:20:56.000000000 +0200
++++ werken.xpath/src/com/werken/xpath/impl/UnAbbrStep.java 2003-03-02 01:56:03.000000000 +0200
+@@ -227,7 +227,7 @@
+
+ if ( node instanceof Element )
+ {
+- List children = ((Element)node).getMixedContent();
++ List children = ((Element)node).getContent();
+
+ results.addAll( applyTo( children,
+ support,
+@@ -235,7 +235,7 @@
+ }
+ else if ( node instanceof Document )
+ {
+- List children = ((Document)node).getMixedContent();
++ List children = ((Document)node).getContent();
+
+ results.addAll( applyTo( children,
+ support,
+@@ -256,7 +256,7 @@
+
+ if ( node instanceof Element )
+ {
+- List children = ((Element)node).getMixedContent();
++ List children = ((Element)node).getContent();
+
+ results.addAll( applyTo( children,
+ support,
+@@ -264,7 +264,7 @@
+ }
+ else if ( node instanceof Document )
+ {
+- List children = ((Document)node).getMixedContent();
++ List children = ((Document)node).getContent();
+
+ results.addAll( applyTo( children,
+ support,
+diff -Nru werken.xpath.orig/test/src/com/werken/xpath/test/Driver.java werken.xpath/test/src/com/werken/xpath/test/Driver.java
+--- werken.xpath.orig/test/src/com/werken/xpath/test/Driver.java 2000-11-09 19:43:30.000000000 +0200
++++ werken.xpath/test/src/com/werken/xpath/test/Driver.java 2003-03-02 01:56:55.000000000 +0200
+@@ -412,7 +412,7 @@
+ elemID = "";
+ }
+
+- resultNode.addAttribute("id", elemID);
++ resultNode.setAttribute("id", elemID);
+ node.addContent( resultNode );
+ results.addContent( node );
+ }
diff --git a/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-tests.patch b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-tests.patch
new file mode 100644
index 000000000000..d26e6185aff3
--- /dev/null
+++ b/dev-java/werken-xpath/files/werken-xpath-0.9.4_beta-jpp-tests.patch
@@ -0,0 +1,10 @@
+--- runtests.sh~ 2000-10-31 23:42:01.000000000 +0200
++++ runtests.sh 2003-03-02 01:59:55.000000000 +0200
+@@ -9,6 +9,6 @@
+ XPATH_CP=./build/werken.xpath.jar
+ TEST_CP=./build/test/classes/
+
+-CP=$ANTLR_CP:$JDOM_CP:$XPATH_CP:$TEST_CP:$XERCES_CP
++CP=$ANTLR_CP:$JDOM_CP:$XPATH_CP:$TEST_CP:$XERCES_CP:$CLASSPATH
+
+ java -classpath $CP $TEST_DRIVER $TESTS_XML
diff --git a/dev-java/werken-xpath/metadata.xml b/dev-java/werken-xpath/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/werken-xpath/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/werken-xpath/werken-xpath-0.9.4_beta.ebuild b/dev-java/werken-xpath/werken-xpath-0.9.4_beta.ebuild
new file mode 100644
index 000000000000..8f8721a90f48
--- /dev/null
+++ b/dev-java/werken-xpath/werken-xpath-0.9.4_beta.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/werken-xpath/werken-xpath-0.9.4_beta.ebuild,v 1.1 2005/12/08 05:19:47 nichoj Exp $
+
+inherit java-pkg eutils versionator
+
+MY_PN=${PN//-/.}
+MY_PV=$(replace_version_separator 3 '-')
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="W3C XPath-Rec implementation for DOM4J"
+HOMEPAGE="http://sourceforge.net/projects/werken-xpath/"
+SRC_URI="mirror://gentoo/${MY_P}-src.tar.gz"
+# This tarball was acquired from jpackage's src rpm of the package by the same
+# name
+
+LICENSE="werken.xpath"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jikes source"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ dev-java/antlr
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4
+ ~dev-java/jdom-1.0_beta9"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Courtesy of JPackages :)
+ epatch ${FILESDIR}/${P}-jpp-compile.patch
+ epatch ${FILESDIR}/${P}-jpp-jdom.patch
+ epatch ${FILESDIR}/${P}-jpp-tests.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from jdom-1.0_beta9
+ java-pkg_jar-from antlr
+}
+
+src_compile() {
+ local antflags="package"
+ use doc && antflags="${antflags} javadoc -Dbuild.javadocs=build/api"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+
+ ant ${antflags} || die "compile failed"
+}
+
+src_install() {
+ java-pkg_dojar build/${MY_PN}.jar
+
+ dodoc README TODO LIMITATIONS
+ use doc && java-pkg_dohtml -r build/api
+ use source && java-pkg_dosrc src/*
+}