summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-01-16 17:48:36 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-01-16 17:48:36 +0000
commita6eabaac7ce7c22f91167e9a382ec024f3204fdf (patch)
tree9f32936cfcd21061a067a627e0d5f5626c4fc684 /dev-java/tomcat-native
parentThe jay programme included with mono uses the old-style BSD 4-clause license (diff)
downloadgentoo-2-a6eabaac7ce7c22f91167e9a382ec024f3204fdf.tar.gz
gentoo-2-a6eabaac7ce7c22f91167e9a382ec024f3204fdf.tar.bz2
gentoo-2-a6eabaac7ce7c22f91167e9a382ec024f3204fdf.zip
Version bump. Fixes bug #255181.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.16.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index f7e08db42c1c..e61629c6885c 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.21 2009/01/10 15:42:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.22 2009/01/16 17:48:36 betelgeuse Exp $
+
+*tomcat-native-1.1.16 (16 Jan 2009)
+
+ 16 Jan 2009; Petteri Räty <betelgeuse@gentoo.org>
+ +tomcat-native-1.1.16.ebuild:
+ Version bump. Fixes bug #255181.
10 Jan 2009; Markus Meier <maekke@gentoo.org> tomcat-native-1.1.15.ebuild:
amd64/x86 stable, bug #253684
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.16.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.16.ebuild
new file mode 100644
index 000000000000..06cb5df48d0c
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.16.ebuild,v 1.1 2009/01/16 17:48:36 betelgeuse Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_compile(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+ emake || die "Could not build libtcnative-1.so"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}