summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-05-22 20:53:28 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-05-22 20:53:28 +0000
commit634002df27a039eaad5d7640547e2f60b4a55782 (patch)
tree6404caac4de04cb5e95076d52680731e351f7658 /dev-java/tomcat-native
parentfix digests; whitespace cleanups; remove apache-tools at patch level (diff)
downloadgentoo-2-634002df27a039eaad5d7640547e2f60b4a55782.tar.gz
gentoo-2-634002df27a039eaad5d7640547e2f60b4a55782.tar.bz2
gentoo-2-634002df27a039eaad5d7640547e2f60b4a55782.zip
Bumped to latest release.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/files/digest-tomcat-native-1.1.103
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.10.ebuild42
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index 616d75bedc30..0f1bf88037e1 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.6 2007/04/12 20:09:27 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.7 2007/05/22 20:53:28 wltjr Exp $
+
+*tomcat-native-1.1.10 (22 May 2007)
+
+ 22 May 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ +tomcat-native-1.1.10.ebuild:
+ Bumped to latest release.
12 Apr 2007; Christian Faulhammer <opfer@gentoo.org>
tomcat-native-1.1.8.ebuild:
diff --git a/dev-java/tomcat-native/files/digest-tomcat-native-1.1.10 b/dev-java/tomcat-native/files/digest-tomcat-native-1.1.10
new file mode 100644
index 000000000000..e45f1ed67083
--- /dev/null
+++ b/dev-java/tomcat-native/files/digest-tomcat-native-1.1.10
@@ -0,0 +1,3 @@
+MD5 8d2eaef338a1a02f3d929a575d5e1453 tomcat-native-1.1.10-src.tar.gz 185398
+RMD160 eac2a2ee8b9beadf74f4885b99797a8fed7b2699 tomcat-native-1.1.10-src.tar.gz 185398
+SHA256 bd2f8f374e3b75a9b0ef0cd8b076fa043a90ffb3c2763dd2daeb2b6dd06f1b79 tomcat-native-1.1.10-src.tar.gz 185398
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.10.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.10.ebuild
new file mode 100644
index 000000000000..dba31209144b
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.10.ebuild,v 1.1 2007/05/22 20:53:28 wltjr Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_compile(){
+ cd ${S}/jni/native
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+ emake || die "Could not build libtcnative-1.so"
+}
+
+src_install() {
+ cd ${S}/jni/native
+ make DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}