summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2008-01-15 03:52:31 +0000
committerWilliam Thomson <wltjr@gentoo.org>2008-01-15 03:52:31 +0000
commit5c91564919960a729f8635f3e8a165114faf1884 (patch)
tree54427a4d74cd9aafabbf01e72dc72895d4da4a3b /dev-java/tomcat-native
parentAdd missing app-arch/unzip DEPEND for bug #205836. (diff)
downloadgentoo-2-5c91564919960a729f8635f3e8a165114faf1884.tar.gz
gentoo-2-5c91564919960a729f8635f3e8a165114faf1884.tar.bz2
gentoo-2-5c91564919960a729f8635f3e8a165114faf1884.zip
Bumped to latest release
(Portage version: 2.1.4)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog10
-rw-r--r--dev-java/tomcat-native/files/digest-tomcat-native-1.1.123
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.12.ebuild43
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index f5fd746aa1d0..242d489d0a51 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.11 2007/10/12 08:32:26 opfer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.12 2008/01/15 03:52:30 wltjr Exp $
+
+*tomcat-native-1.1.12 (15 Jan 2008)
+
+ 15 Jan 2008; William L. Thomson Jr. <wltjr@gentoo.org>
+ +tomcat-native-1.1.12.ebuild:
+ Bumped to latest release
12 Oct 2007; Christian Faulhammer <opfer@gentoo.org> ChangeLog:
stable x86, security bug 195576
diff --git a/dev-java/tomcat-native/files/digest-tomcat-native-1.1.12 b/dev-java/tomcat-native/files/digest-tomcat-native-1.1.12
new file mode 100644
index 000000000000..4b1ad198f2d2
--- /dev/null
+++ b/dev-java/tomcat-native/files/digest-tomcat-native-1.1.12
@@ -0,0 +1,3 @@
+MD5 7954b3fb31d4bec2617525b9977abf70 tomcat-native-1.1.12-src.tar.gz 187968
+RMD160 fcd19fcd1db1696013c6c280e73cf75684e0b7a6 tomcat-native-1.1.12-src.tar.gz 187968
+SHA256 70dd3ea02b9cf9b52f27da9e479b94efb0f0edfde3d6a485e60324189fb3e414 tomcat-native-1.1.12-src.tar.gz 187968
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.12.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.12.ebuild
new file mode 100644
index 000000000000..4feed1f4ca65
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.12.ebuild,v 1.1 2008/01/15 03:52:30 wltjr Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_compile(){
+ cd "${S}"/jni/native
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+ emake || die "Could not build libtcnative-1.so"
+}
+
+src_install() {
+ cd "${S}"/jni/native
+ make DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}