summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-07 13:39:28 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-07 13:39:28 +0000
commit640753fe4dadee02198ad10cd7424f9a4b747eca (patch)
tree7aad4988a08946b9cb96c662e0972db9ff9f9e7e /dev-java/swt
parentRemove KDE3 support. (diff)
downloadgentoo-2-640753fe4dadee02198ad10cd7424f9a4b747eca.tar.gz
gentoo-2-640753fe4dadee02198ad10cd7424f9a4b747eca.tar.bz2
gentoo-2-640753fe4dadee02198ad10cd7424f9a4b747eca.zip
Update the deps to make sure there's XTest.h - bug #292244.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/swt')
-rw-r--r--dev-java/swt/ChangeLog6
-rw-r--r--dev-java/swt/swt-3.3.1.1-r1.ebuild6
-rw-r--r--dev-java/swt/swt-3.4-r4.ebuild5
-rw-r--r--dev-java/swt/swt-3.5.1.ebuild5
-rw-r--r--dev-java/swt/swt-3.5.ebuild5
5 files changed, 18 insertions, 9 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index 855a4ee9430c..15e965a1e0d9 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/swt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.114 2009/11/07 11:19:27 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.115 2009/11/07 13:39:28 caster Exp $
+
+ 07 Nov 2009; Vlastimil Babka <caster@gentoo.org> swt-3.3.1.1-r1.ebuild,
+ swt-3.4-r4.ebuild, swt-3.5.ebuild, swt-3.5.1.ebuild:
+ Update the deps to make sure there's XTest.h - bug #292244.
07 Nov 2009; Vlastimil Babka <caster@gentoo.org> swt-3.5.ebuild,
swt-3.5.1.ebuild:
diff --git a/dev-java/swt/swt-3.3.1.1-r1.ebuild b/dev-java/swt/swt-3.3.1.1-r1.ebuild
index 96c7b8fe69a8..f35dbf9ce29d 100644
--- a/dev-java/swt/swt-3.3.1.1-r1.ebuild
+++ b/dev-java/swt/swt-3.3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.3.1.1-r1.ebuild,v 1.6 2009/11/03 21:20:10 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.3.1.1-r1.ebuild,v 1.7 2009/11/07 13:39:28 caster Exp $
EAPI="1"
@@ -56,12 +56,14 @@ COMMON=">=dev-libs/glib-2.6
virtual/glu
)
x11-libs/libXtst"
+
+# libXtst/xextproto is done like this due to the XTest.h move - bug #292244
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
x11-libs/libX11
x11-libs/libXrender
x11-libs/libXt
- x11-proto/xextproto
+ || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1 )
dev-util/pkgconfig
${COMMON}"
diff --git a/dev-java/swt/swt-3.4-r4.ebuild b/dev-java/swt/swt-3.4-r4.ebuild
index 9c3fb2a44217..8abff9a172ff 100644
--- a/dev-java/swt/swt-3.4-r4.ebuild
+++ b/dev-java/swt/swt-3.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.4-r4.ebuild,v 1.5 2009/11/03 21:20:10 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.4-r4.ebuild,v 1.6 2009/11/07 13:39:28 caster Exp $
EAPI="1"
@@ -52,6 +52,7 @@ COMMON=">=dev-libs/glib-2.6
# Use a blocker to avoid file collisions when upgrading to the slotted version
# We cannot use slotmove, java packages are expected to be in /usr/share/PN-SLOT
# so this is the only way to prevent collisions
+# libXtst/xextproto is done like this due to the XTest.h move - bug #292244
DEPEND=">=virtual/jdk-1.4
!=dev-java/swt-3.4*:3
@@ -59,7 +60,7 @@ DEPEND=">=virtual/jdk-1.4
x11-libs/libX11
x11-libs/libXrender
x11-libs/libXt
- x11-proto/xextproto
+ || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1 )
x11-proto/inputproto
dev-util/pkgconfig
${COMMON}"
diff --git a/dev-java/swt/swt-3.5.1.ebuild b/dev-java/swt/swt-3.5.1.ebuild
index ca80d776c3d4..991ea0bb2996 100644
--- a/dev-java/swt/swt-3.5.1.ebuild
+++ b/dev-java/swt/swt-3.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.1.ebuild,v 1.2 2009/11/07 11:19:27 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.1.ebuild,v 1.3 2009/11/07 13:39:28 caster Exp $
EAPI=2
@@ -52,13 +52,14 @@ COMMON=">=dev-libs/glib-2.6
# Use a blocker to avoid file collisions when upgrading to the slotted version
# We cannot use slotmove, java packages are expected to be in /usr/share/PN-SLOT
# so this is the only way to prevent collisions
+# libXtst/xextproto is done like this due to the XTest.h move - bug #292244
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
x11-libs/libX11
x11-libs/libXrender
x11-libs/libXt
- x11-proto/xextproto
+ || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1 )
x11-proto/inputproto
dev-util/pkgconfig
${COMMON}"
diff --git a/dev-java/swt/swt-3.5.ebuild b/dev-java/swt/swt-3.5.ebuild
index e1e47c6589bb..5f976012fb85 100644
--- a/dev-java/swt/swt-3.5.ebuild
+++ b/dev-java/swt/swt-3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.ebuild,v 1.5 2009/11/07 11:19:27 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.ebuild,v 1.6 2009/11/07 13:39:28 caster Exp $
EAPI=2
@@ -52,13 +52,14 @@ COMMON=">=dev-libs/glib-2.6
# Use a blocker to avoid file collisions when upgrading to the slotted version
# We cannot use slotmove, java packages are expected to be in /usr/share/PN-SLOT
# so this is the only way to prevent collisions
+# libXtst/xextproto is done like this due to the XTest.h move - bug #292244
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
x11-libs/libX11
x11-libs/libXrender
x11-libs/libXt
- x11-proto/xextproto
+ || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1 )
x11-proto/inputproto
dev-util/pkgconfig
${COMMON}"