summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-18 19:25:14 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-18 19:25:14 +0000
commitbfa2ff29ee58ef6a911dff579e49fd3b6e867a63 (patch)
tree7767704bb3b6dff4e0579b1e68541537d4a70d5f /dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
parentFixed compilation problem with missing inttypes.h. (diff)
downloadgentoo-2-bfa2ff29ee58ef6a911dff579e49fd3b6e867a63.tar.gz
gentoo-2-bfa2ff29ee58ef6a911dff579e49fd3b6e867a63.tar.bz2
gentoo-2-bfa2ff29ee58ef6a911dff579e49fd3b6e867a63.zip
Respect the global USE=nsplugin instead of the local USE=browserplugin
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild')
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
index 65317a4d7fdf..5568fcd17d48 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild,v 1.6 2005/09/14 15:59:11 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild,v 1.7 2005/10/18 19:20:31 agriffis Exp $
inherit java eutils
@@ -15,7 +15,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm-1.4.2"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="browserplugin mozilla"
+IUSE="nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.1.5
sys-apps/sed"
@@ -78,7 +78,7 @@ src_install() {
dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt
dohtml Welcome.html ControlPanel.html
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -147,9 +147,9 @@ pkg_postinst () {
echo
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
+ ewarn "has been renamed to 'nsplugin' please update your USE"
fi
}