summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-23 12:14:06 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-23 12:14:06 +0000
commit45a7ba8f14ccd9af05afefaf607072154cbd5d17 (patch)
tree0ea0e034624d0260e1ca872836087bc74f28fc71 /dev-java/sun-jimi/sun-jimi-1.0.ebuild
parentupdate openldap note. (diff)
downloadgentoo-2-45a7ba8f14ccd9af05afefaf607072154cbd5d17.tar.gz
gentoo-2-45a7ba8f14ccd9af05afefaf607072154cbd5d17.tar.bz2
gentoo-2-45a7ba8f14ccd9af05afefaf607072154cbd5d17.zip
Should be sun-jimi, not sun-jimi-bin, of course.
Diffstat (limited to 'dev-java/sun-jimi/sun-jimi-1.0.ebuild')
-rw-r--r--dev-java/sun-jimi/sun-jimi-1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/sun-jimi/sun-jimi-1.0.ebuild b/dev-java/sun-jimi/sun-jimi-1.0.ebuild
new file mode 100644
index 000000000000..a46120be6025
--- /dev/null
+++ b/dev-java/sun-jimi/sun-jimi-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jimi/sun-jimi-1.0.ebuild,v 1.1 2004/12/23 12:14:06 karltk Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jimi is a class library for managing images."
+HOMEPAGE="http://java.sun.com/products/jimi/"
+SRC_URI="jimi1_0.zip"
+LICENSE="sun-bcla-jimi"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc amd64"
+IUSE="doc"
+DEPEND="virtual/jre
+ app-arch/unzip"
+RESTRICT="fetch"
+
+S=${WORKDIR}/Jimi
+
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=7259-jimi_sdk-1.0-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from the following url and place it in ${DISTDIR}"
+ einfo "${DOWNLOAD_URL} "
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -rf src/classes/*
+}
+
+src_compile() {
+ cd ${S}/src
+ javac -target 1.2 -classpath . -d classes $(cat main_classes.txt) || die "failes to compile"
+ jar -cf ${PN}.jar -C classes . || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar src/${PN}.jar
+
+ dodoc Readme License
+ use doc && java-pkg_dohtml -r docs/*
+}