summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-23 16:40:48 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-23 16:40:48 +0000
commitc89ee17a76d3e524879cc25c151b0565d18be9af (patch)
treeca736e6905022ea2bd91cb2be877dc169753a284 /dev-java/sun-jdk
parentAdded Sun's dlj-1.1 license (diff)
downloadgentoo-2-c89ee17a76d3e524879cc25c151b0565d18be9af.tar.gz
gentoo-2-c89ee17a76d3e524879cc25c151b0565d18be9af.tar.bz2
gentoo-2-c89ee17a76d3e524879cc25c151b0565d18be9af.zip
Revision bump to use DLJ distfiles (bug #133590).
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog8
-rw-r--r--dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.07-r16
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.07-r1.ebuild179
3 files changed, 192 insertions, 1 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index bfeb6d283fc0..84da7b31e5a6 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.151 2006/07/06 10:46:51 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.152 2006/07/23 16:40:48 nichoj Exp $
+
+*sun-jdk-1.5.0.07-r1 (23 Jul 2006)
+
+ 23 Jul 2006; Joshua Nichols <jnichols@gentoo.org>
+ +sun-jdk-1.5.0.07-r1.ebuild:
+ Revision bump to use DLJ distfiles (bug #133590).
06 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
sun-jdk-1.2.2.017.ebuild, sun-jdk-1.3.1.17.ebuild,
diff --git a/dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.07-r1 b/dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.07-r1
new file mode 100644
index 000000000000..0e7884507e8e
--- /dev/null
+++ b/dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.07-r1
@@ -0,0 +1,6 @@
+MD5 cbf4fee8c737ed6b1d5288dc0f6dbe3c jdk-1_5_0_07-distro-linux-amd64.bin 43811573
+RMD160 1b6e4d557d4e171b402e6a955364ee32f6c20b43 jdk-1_5_0_07-distro-linux-amd64.bin 43811573
+SHA256 bf798c43fc077d893adff1337fc03e0e0017e46f1b03dab884d2aa66690e4330 jdk-1_5_0_07-distro-linux-amd64.bin 43811573
+MD5 d7bf7e986ab185c830d11f93f18b3930 jdk-1_5_0_07-distro-linux-i586.bin 49100762
+RMD160 2ea192d0e1db5c617b5b4773f5fe169f038a72a1 jdk-1_5_0_07-distro-linux-i586.bin 49100762
+SHA256 68c5fe5c44e5f3a0d83c34ddcd73d8e9ceede1ccb79da46019b45825be443e5a jdk-1_5_0_07-distro-linux-i586.bin 49100762
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.07-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.07-r1.ebuild
new file mode 100644
index 000000000000..7d6c8da97bac
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.07-r1.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.07-r1.ebuild,v 1.1 2006/07/23 16:40:48 nichoj Exp $
+
+inherit java-vm-2 eutils
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+S="${WORKDIR}/jdk${MY_PVL}"
+
+if use x86; then
+ At=jdk-${MY_PVA}-distro-linux-i586.bin
+elif use amd64; then
+ At=jdk-${MY_PVA}-distro-linux-amd64.bin
+fi
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/jdk-${MY_PVA}-distro-linux-i586.bin )
+ amd64? ( http://download.java.net/dlj/binaries/jdk-${MY_PVA}-distro-linux-amd64.bin )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="~x86 ~amd64 -*"
+RESTRICT="nostrip"
+IUSE="X alsa doc examples nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+#
+DEPEND=">=dev-java/java-config-1.2
+ sys-apps/sed
+ doc? ( =dev-java/java-sdk-docs-1.5.0* )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ doc? ( =dev-java/java-sdk-docs-1.5.0* )
+ X? ( || ( ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/lib/javaws.jar jre/lib/deploy.jar"
+
+# this is needed for proper operating under a PaX kernel without activated grsecurity acl
+CHPAX_CONSERVATIVE_FLAGS="pemsv"
+
+#FETCH_SDK="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jdk-${MY_PVL}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+#FETCH_JCE="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jce_policy-${PV%.*}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+# if use jce; then
+# if [ ! -r ${DISTDIR}/${jcefile} ]; then
+# die "cannot read ${jcefile}. Please check the permission and try again."
+# fi
+# fi
+
+ sh ${DISTDIR}/${At} --accept-license --unpack || die "Failed to unpack"
+
+ ${S}/bin/java -client -Xshare:dump
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -pPR $i ${D}/opt/${P}/ || die "failed to copy"
+ done
+ dodoc COPYRIGHT README.html
+ dohtml README.html
+ dodir /opt/${P}/share/
+
+ cp -pPR src.zip ${D}/opt/${P}/share/
+
+ if use examples; then
+ cp -pPR demo ${D}/opt/${P}/share/
+ if ( use x86 || use amd64 ); then
+ cp -pPR sample ${D}/opt/${P}/share/
+ fi
+ fi
+
+# if use jce ; then
+# cd ${D}/opt/${P}/jre/lib/security
+# unzip ${DISTDIR}/${jcefile} || die "failed to unzip jce"
+# mv jce unlimited-jce
+# dodir /opt/${P}/jre/lib/security/strong-jce
+# mv ${D}/opt/${P}/jre/lib/security/US_export_policy.jar ${D}/opt/${P}/jre/lib/security/strong-jce
+# mv ${D}/opt/${P}/jre/lib/security/local_policy.jar ${D}/opt/${P}/jre/lib/security/strong-jce
+# dosym /opt/${P}/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
+# dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
+# fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+ -e "s/\(Name=Java\)/\1 Control Panel/" \
+ ${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_java.desktop
+
+ domenu ${T}/sun_java.desktop
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ # if chpax is on the target system, set the appropriate PaX flags
+ # this will not hurt the binary, it modifies only unused ELF bits
+ # but may confuse things like AV scanners and automatic tripwire
+ if has_version sys-apps/chpax
+ then
+ echo
+ einfo "setting up conservative PaX flags for jar, javac and java"
+
+ for paxkills in "jar" "javac" "java" "javah" "javadoc"
+ do
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/$paxkills
+ done
+
+ # /opt/$VM/jre/bin/java_vm
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/jre/bin/java_vm
+
+ einfo "you should have seen lots of chpax output above now"
+ ewarn "make sure the grsec ACL contains those entries also"
+ ewarn "because enabling it will override the chpax setting"
+ ewarn "on the physical files - help for PaX and grsecurity"
+ ewarn "can be given by #gentoo-hardened + hardened@gentoo.org"
+ fi
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ einfo " Be careful: ${P}'s Java compiler uses"
+ einfo " '-source 1.5' as default. Some keywords such as 'enum'"
+ einfo " are not valid identifiers any more in that mode,"
+ einfo " which can cause incompatibility with certain sources."
+}