summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-06-06 18:07:50 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-06-06 18:07:50 +0000
commit599c37880772c4be38858ae9441190f88d8ce8fb (patch)
tree319d58782dad775a4068279c40997ab4ff7497d7 /dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild
parentStable on amd64. (diff)
downloadgentoo-2-599c37880772c4be38858ae9441190f88d8ce8fb.tar.gz
gentoo-2-599c37880772c4be38858ae9441190f88d8ce8fb.tar.bz2
gentoo-2-599c37880772c4be38858ae9441190f88d8ce8fb.zip
version bump, directly to stable because sun no longer has the old file downloadable and the license forbits mirroring -- will be replaces by gnu-jaf soon.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild')
-rw-r--r--dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild b/dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild
new file mode 100644
index 000000000000..5f99f6654853
--- /dev/null
+++ b/dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jaf-bin/sun-jaf-bin-1.0.2.2.ebuild,v 1.1 2005/06/06 18:07:50 axxo Exp $
+
+inherit java-pkg
+
+At="jaf-1_0_2-upd2.zip"
+DESCRIPTION="Sun's JavaBeans Activation Framework (JAF)"
+SRC_URI="${At}"
+HOMEPAGE="http://java.sun.com/products/javabeans/glasgow/jaf.html"
+KEYWORDS="x86 ppc sparc amd64 ppc64"
+LICENSE="sun-bcla-jaf"
+SLOT="0"
+DEPEND=">=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jdk-1.2"
+IUSE="doc"
+RESTRICT="fetch"
+S=${WORKDIR}/jaf-${PV%.*}
+
+pkg_nofetch() {
+ einfo " "
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo " "
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Download ${At}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo " "
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodoc RELNOTES.txt README.txt LICENSE.txt
+ use doc && java-pkg_dohtml -r docs/
+ java-pkg_dojar activation.jar
+}