summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-07-16 22:42:29 +0000
committerVlastimil Babka <caster@gentoo.org>2008-07-16 22:42:29 +0000
commit70f1a37cb96ede38221d788c8966af1323d3f1d7 (patch)
treee3044384f45d7383cde9dd75540b4fc745aa0d45 /dev-java/rhino
parentversion bump for various bug fixes and translation updates. (diff)
downloadgentoo-2-70f1a37cb96ede38221d788c8966af1323d3f1d7.tar.gz
gentoo-2-70f1a37cb96ede38221d788c8966af1323d3f1d7.tar.bz2
gentoo-2-70f1a37cb96ede38221d788c8966af1323d3f1d7.zip
Undo workaround for bug #145769 as it is no longer needed.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'dev-java/rhino')
-rw-r--r--dev-java/rhino/ChangeLog7
-rw-r--r--dev-java/rhino/rhino-1.5.5-r5.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-java/rhino/ChangeLog b/dev-java/rhino/ChangeLog
index 95dc649431ee..f447c6c3144e 100644
--- a/dev-java/rhino/ChangeLog
+++ b/dev-java/rhino/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/rhino
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/ChangeLog,v 1.59 2008/01/19 16:23:49 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/ChangeLog,v 1.60 2008/07/16 22:42:29 caster Exp $
+
+*rhino-1.5.5-r5 (16 Jul 2008)
+
+ 16 Jul 2008; Vlastimil Babka <caster@gentoo.org> +rhino-1.5.5-r5.ebuild:
+ Undo workaround for bug #145769 as it is no longer needed.
19 Jan 2008; Petteri Räty <betelgeuse@gentoo.org> -rhino-1.6.1-r3.ebuild:
Delete old version.
diff --git a/dev-java/rhino/rhino-1.5.5-r5.ebuild b/dev-java/rhino/rhino-1.5.5-r5.ebuild
new file mode 100644
index 000000000000..7c7a8479f5d5
--- /dev/null
+++ b/dev-java/rhino/rhino-1.5.5-r5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5.5-r5.ebuild,v 1.1 2008/07/16 22:42:29 caster Exp $
+
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P="rhino1_5R5"
+DESCRIPTION="Rhino is an open-source Java implementation of JavaScript."
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/js/${MY_P}.zip
+ mirror://gentoo/rhino-swing-ex-1.0.zip"
+HOMEPAGE="http://www.mozilla.org/rhino/"
+LICENSE="NPL-1.1"
+SLOT="1.5"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="dev-java/ant-core
+ >=virtual/jdk-1.3
+ app-arch/unzip
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.zip
+ cd "${S}"
+ mkdir build/
+ epatch "${FILESDIR}/${PV}_jdk15.patch"
+ epatch "${FILESDIR}/00_dont-fetch-swing-ex.patch"
+ cp "${DISTDIR}/rhino-swing-ex-1.0.zip" build/swingExSrc.zip || die "unpack error"
+}
+
+src_compile() {
+ eant jar
+}
+
+src_install() {
+ java-pkg_dolauncher jsscript-${SLOT} \
+ --main org.mozilla.javascript.tools.shell.Main
+ java-pkg_dojar build/*/js.jar
+ use source && java-pkg_dosrc {src,toolsrc}/org
+ use doc && java-pkg_dohtml -r docs/*
+}