summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2009-01-10 13:13:06 +0000
committerAlistair Bush <ali_bush@gentoo.org>2009-01-10 13:13:06 +0000
commit73af7d3a7e8cbe222c19cb125e70367237f21e85 (patch)
treea72368b02e32c73e06f8a995c5d0813b6fd0a028 /dev-java/jython
parentVersion bump #254098. (diff)
downloadgentoo-2-73af7d3a7e8cbe222c19cb125e70367237f21e85.tar.gz
gentoo-2-73af7d3a7e8cbe222c19cb125e70367237f21e85.tar.bz2
gentoo-2-73af7d3a7e8cbe222c19cb125e70367237f21e85.zip
Cleanup old ebuild and fix incorrect licence see #252951
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'dev-java/jython')
-rw-r--r--dev-java/jython/ChangeLog6
-rw-r--r--dev-java/jython/jython-2.1-r10.ebuild94
-rw-r--r--dev-java/jython/jython-2.1-r11.ebuild6
3 files changed, 8 insertions, 98 deletions
diff --git a/dev-java/jython/ChangeLog b/dev-java/jython/ChangeLog
index 0d47ae83d4f6..19ab8235e90e 100644
--- a/dev-java/jython/ChangeLog
+++ b/dev-java/jython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/jython
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.58 2009/01/01 11:20:28 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.59 2009/01/10 13:13:06 ali_bush Exp $
+
+ 10 Jan 2009; Alistair Bush <ali_bush@gentoo.org> -jython-2.1-r10.ebuild,
+ jython-2.1-r11.ebuild:
+ Cleanup old ebuild and fix incorrect licence see #252951
01 Jan 2009; Alistair Bush <ali_bush@gentoo.org> jython-2.2.1-r1.ebuild:
Corrent Licence. See #252951
diff --git a/dev-java/jython/jython-2.1-r10.ebuild b/dev-java/jython/jython-2.1-r10.ebuild
deleted file mode 100644
index c0055fd345fe..000000000000
--- a/dev-java/jython/jython-2.1-r10.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r10.ebuild,v 1.11 2007/03/04 20:26:19 peper Exp $
-
-inherit base java-pkg-2
-
-DESCRIPTION="An implementation of Python written in Java"
-HOMEPAGE="http://www.jython.org"
-MY_PV="21"
-#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="JPython"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="readline source doc"
-# servlet
-
-RDEPEND=">=virtual/jre-1.3
- readline? ( >=dev-java/libreadline-java-0.8.0 )"
-# servlet? ( >=www-servers/tomcat-5.0 )
-DEPEND=">=virtual/jdk-1.3
- source? ( app-arch/zip )
- ${RDEPEND}"
-
-PATCHES="${FILESDIR}/${PV}-assert.patch
- ${FILESDIR}/${PV}-assert-SimpleCompiler.py.patch"
-
-src_compile() {
- local cp="."
- local exclude=""
-
- if use readline ; then
- cp=${cp}:$(java-pkg_getjars libreadline-java)
- else
- exclude="${exclude} ! -name ReadlineConsole.java"
- fi
-
- #if use servlet; then
- # cp=${cp}:$(java-pkg_getjars servlet)
- #else
- exclude="${exclude} ! -name PyServlet.java"
- #fi
-
- ejavac -classpath ${cp} -nowarn $(find org -name "*.java" ${exclude})
-
- find org -name "*.class" | xargs jar cf ${PN}.jar
-}
-
-src_install() {
- java-pkg_dojar ${PN}.jar
-
- dodoc README.txt NEWS ACKNOWLEDGMENTS
- use doc && java-pkg_dohtml -A .css .jpg .gif -r Doc/*
-
- java-pkg_dolauncher jythonc \
- --main "org.python.util.jython" \
- --java_args "-Dpython.home=/usr/share/jython" \
- --pkg_args "/usr/share/jython/tools/jythonc/jythonc.py"
-
- java-pkg_dolauncher jython \
- --main "org.python.util.jython" \
- --java_args "-Dpython.home=/usr/share/jython"
-
- dodir /usr/share/jython/cachedir
- chmod a+rw ${D}/usr/share/jython/cachedir
-
- rm Demo/jreload/example.jar
- insinto /usr/share/${PN}
- doins -r Lib Demo registry
-
- insinto /usr/share/${PN}/tools
- doins -r Tools/*
-
- use source && java-pkg_dosrc com org
-}
-
-pkg_postinst() {
- if use readline; then
- elog "To use readline you need to add the following to your registry"
- elog
- elog "python.console=org.python.util.ReadlineConsole"
- elog "python.console.readlinelib=GnuReadline"
- elog
- elog "The global registry can be found in /usr/share/${PN}/registry"
- elog "User registry in \$HOME/.jython"
- elog "See http://www.jython.org/docs/registry.html for more information"
- elog ""
- fi
-
- elog "This revision renames org.python.core.Py.assert to assert_."
- elog "This is the solution that upstream will use in the next release."
- elog "Just note that this revision is not API compatible with vanilla 2.1."
- elog "https://bugs.gentoo.org/show_bug.cgi?id=142099"
-}
diff --git a/dev-java/jython/jython-2.1-r11.ebuild b/dev-java/jython/jython-2.1-r11.ebuild
index 39f7a92d5052..a2675866a268 100644
--- a/dev-java/jython/jython-2.1-r11.ebuild
+++ b/dev-java/jython/jython-2.1-r11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r11.ebuild,v 1.8 2007/07/11 19:58:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r11.ebuild,v 1.9 2009/01/10 13:13:06 ali_bush Exp $
inherit base java-pkg-2
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.jython.org"
MY_PV="21"
#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="JPython"
+LICENSE="Jython"
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
IUSE="readline source doc"