summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-08-31 04:11:21 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-08-31 04:11:21 +0000
commitf38c2b5c8615f9e8c88c2cde3b9d57d58b05d8c2 (patch)
treedc72c499818f760a64a37e21af15ee0601b726e8 /dev-java/jsx/jsx-1.0.7.5.ebuild
parentMarking x86 (Manifest recommit) (diff)
downloadgentoo-2-f38c2b5c8615f9e8c88c2cde3b9d57d58b05d8c2.tar.gz
gentoo-2-f38c2b5c8615f9e8c88c2cde3b9d57d58b05d8c2.tar.bz2
gentoo-2-f38c2b5c8615f9e8c88c2cde3b9d57d58b05d8c2.zip
Version bump and cleanup
Diffstat (limited to 'dev-java/jsx/jsx-1.0.7.5.ebuild')
-rw-r--r--dev-java/jsx/jsx-1.0.7.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jsx/jsx-1.0.7.5.ebuild b/dev-java/jsx/jsx-1.0.7.5.ebuild
new file mode 100644
index 000000000000..c0700ee56002
--- /dev/null
+++ b/dev-java/jsx/jsx-1.0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jsx/jsx-1.0.7.5.ebuild,v 1.1 2004/08/31 04:11:21 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Java Serialization to XML (JSX) allows you to write and read any Java object graph as XML data with one line of code"
+HOMEPAGE="http://www.csse.monash.edu.au/~bren/JSX/"
+SRC_URI="http://www.csse.monash.edu.au/~bren/JSX/freeJSX${PV}.jar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=">=virtual/jdk-1.2
+ dev-java/java-config"
+RDEPEND=">=virtual/jre-1.2"
+RESTRICT="nomirror"
+
+S=${WORKDIR}
+
+
+src_unpack() {
+ jar xf ${DISTDIR}/${A}
+}
+
+src_compile() {
+ rm -f JSX/*.class JSX/magic/*.class
+ $(java-config -c) JSX/*.java JSX/magic/*.java || die "compilation failed"
+}
+
+src_install() {
+ dodoc JSX/readme.txt
+ jar cf jsx.jar JSX/*.class JSX/magic/*.class || die "failed to create jar"
+ java-pkg_dojar jsx.jar
+}
+