summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-10 22:01:17 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-10 22:01:17 +0000
commit8b381e58fe4450e843a23de14c06412ea90089b7 (patch)
tree8eefc3cdeb1c9bcfc62be83d1c77ba4b2d57822b /dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
parentMoved to dev-scheme/guile. (diff)
downloadgentoo-2-8b381e58fe4450e843a23de14c06412ea90089b7.tar.gz
gentoo-2-8b381e58fe4450e843a23de14c06412ea90089b7.tar.bz2
gentoo-2-8b381e58fe4450e843a23de14c06412ea90089b7.zip
Version bump using generation 2. Added src_test support and examples and source use flags.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild')
-rw-r--r--dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
new file mode 100644
index 000000000000..36c6ca3af8c7
--- /dev/null
+++ b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild,v 1.1 2007/01/10 22:01:17 betelgeuse Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_V=${PV//./_}
+DESCRIPTION="JGoodies Animation Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/animation-${MY_V}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc examples source test"
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4
+ app-arch/unzip
+ source? ( app-arch/zip )
+ test? ( dev-java/junit dev-java/ant-tasks )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/animation-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Remove the packaged jar
+ rm -v lib/*.jar *.jar
+
+ # Copy the Gentoo'ized build.xml
+ # cp ${FILESDIR}/build-${PV}.xml ${S}
+ xml-rewrite.py -f build.xml -d -e javac -a bootclasspath \
+ || die "Failed to fix bootclasspath"
+}
+src_compile() {
+ eant jar # precompiled javadocs
+}
+
+src_test() {
+ eant test -Djunit.jar.present=true \
+ -Djunit.jar=$(java-pkg_getjar junit junit.jar)
+}
+
+src_install() {
+ java-pkg_dojar build/animation.jar
+
+ dodoc RELEASE-NOTES.txt
+ dohtml README.html
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/core/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/tutorial/com
+ fi
+}