summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2005-08-02 19:46:37 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2005-08-02 19:46:37 +0000
commit3fc62e15e9dc524edfcf7d2c4940f71e740eb02d (patch)
treeef27a8e4d6478facfc062bd9724f42e732f69fc6 /dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild
parentpdf files doesn't need to be gziped, bug #97095 (diff)
downloadgentoo-2-3fc62e15e9dc524edfcf7d2c4940f71e740eb02d.tar.gz
gentoo-2-3fc62e15e9dc524edfcf7d2c4940f71e740eb02d.tar.bz2
gentoo-2-3fc62e15e9dc524edfcf7d2c4940f71e740eb02d.zip
version bump, resolves bug 100539
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild')
-rw-r--r--dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild b/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild
new file mode 100644
index 000000000000..dfa968737841
--- /dev/null
+++ b/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild,v 1.1 2005/08/02 19:46:36 betelgeuse Exp $
+
+inherit eutils java-pkg
+
+MY_PN="jdic"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="The JDesktop Integration Components (JDIC) tray icon API"
+HOMEPAGE="https://jdic.dev.java.net/"
+SRC_URI="https://jdic.dev.java.net/files/documents/880/16466/${MY_P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples jikes source"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ app-arch/unzip
+ jikes? ( >=dev-java/jikes-1.21 )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}-src/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.8.7-gentoo.patch
+}
+
+src_compile() {
+ local antflags="buildtray"
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant build failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${MY_P}-${PV}-src/
+
+ cd ${S}/dist/linux
+ java-pkg_dojar jdic.jar
+ java-pkg_doso libtray.so
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc ${S}/src/unix/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r ${S}/demo/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}