summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2010-01-24 17:26:54 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2010-01-24 17:26:54 +0000
commit9f4c96a5ab792d31a5136ac8f616b1fa81f6b643 (patch)
tree2cbeea2ab3d32c163d7850f2dd2b744e9742857b /dev-java/jcifs
parentStable for HPPA (bug #302001). (diff)
downloadgentoo-2-9f4c96a5ab792d31a5136ac8f616b1fa81f6b643.tar.gz
gentoo-2-9f4c96a5ab792d31a5136ac8f616b1fa81f6b643.tar.bz2
gentoo-2-9f4c96a5ab792d31a5136ac8f616b1fa81f6b643.zip
Version bump. Fixes bug #302053.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-java/jcifs')
-rw-r--r--dev-java/jcifs/ChangeLog9
-rw-r--r--dev-java/jcifs/jcifs-1.3.13.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-java/jcifs/ChangeLog b/dev-java/jcifs/ChangeLog
index b13b9e827a07..f966775fe9d0 100644
--- a/dev-java/jcifs/ChangeLog
+++ b/dev-java/jcifs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jcifs
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jcifs/ChangeLog,v 1.15 2009/01/03 17:24:26 serkan Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcifs/ChangeLog,v 1.16 2010/01/24 17:26:54 betelgeuse Exp $
+
+*jcifs-1.3.13 (24 Jan 2010)
+
+ 24 Jan 2010; Petteri Räty <betelgeuse@gentoo.org> +jcifs-1.3.13.ebuild:
+ Version bump. Fixes bug #302053.
*jcifs-1.3.2 (03 Jan 2009)
diff --git a/dev-java/jcifs/jcifs-1.3.13.ebuild b/dev-java/jcifs/jcifs-1.3.13.ebuild
new file mode 100644
index 000000000000..158ce7475c80
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcifs/jcifs-1.3.13.ebuild,v 1.1 2010/01/24 17:26:54 betelgeuse Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="http://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="http://jcifs.samba.org/"
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+RDEPEND=">=virtual/jre-1.4
+ dev-java/servletapi:2.4"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+IUSE=""
+
+S=${WORKDIR}/${P/-/_}
+
+java_prepare() {
+ rm -v *.jar || die
+ rm -v examples/*.class || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_EXTRA_ARGS="-DhasServlet=true"
+EANT_GENTOO_CLASSPATH="servletapi-2.4"
+
+src_install() {
+ java-pkg_newjar ${P}.jar
+
+ dodoc README.txt || die
+ # other stuff besides javadocs
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples examples
+}