summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 23:06:08 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 23:06:08 +0000
commit2fb2840ac7413d5fb60fee468056df49819056cb (patch)
treefcb86054a140fd2944fda3282f2ec07f2c391d56 /dev-java/commons-transaction
parent- qlist, qcache, qlop and qfile updates. including bugs 115733 139825 140019 (diff)
downloadgentoo-2-2fb2840ac7413d5fb60fee468056df49819056cb.tar.gz
gentoo-2-2fb2840ac7413d5fb60fee468056df49819056cb.tar.bz2
gentoo-2-2fb2840ac7413d5fb60fee468056df49819056cb.zip
Migrated to Generation 2.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'dev-java/commons-transaction')
-rw-r--r--dev-java/commons-transaction/ChangeLog10
-rw-r--r--dev-java/commons-transaction/commons-transaction-1.0.1-r1.ebuild49
-rw-r--r--dev-java/commons-transaction/files/digest-commons-transaction-1.0.12
-rw-r--r--dev-java/commons-transaction/files/digest-commons-transaction-1.0.1-r13
4 files changed, 62 insertions, 2 deletions
diff --git a/dev-java/commons-transaction/ChangeLog b/dev-java/commons-transaction/ChangeLog
index 12126a76f3c6..c9e5447e779e 100644
--- a/dev-java/commons-transaction/ChangeLog
+++ b/dev-java/commons-transaction/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-transaction
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-transaction/ChangeLog,v 1.2 2005/07/12 13:29:02 axxo Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-transaction/ChangeLog,v 1.3 2006/07/22 23:06:08 nelchael Exp $
+
+*commons-transaction-1.0.1-r1 (22 Jul 2006)
+
+ 22 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +commons-transaction-1.0.1-r1.ebuild:
+ Migrated to Generation 2.
12 Jul 2005; Thomas Matthijs <axxo@gentoo.org>
commons-transaction-1.0.1.ebuild:
diff --git a/dev-java/commons-transaction/commons-transaction-1.0.1-r1.ebuild b/dev-java/commons-transaction/commons-transaction-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..b694f2fdc0e8
--- /dev/null
+++ b/dev-java/commons-transaction/commons-transaction-1.0.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-transaction/commons-transaction-1.0.1-r1.ebuild,v 1.1 2006/07/22 23:06:08 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Transaction aims at providing lightweight, standardized, well tested and efficient implementations of utility classes commonly used in transactional Java programming."
+HOMEPAGE="http://jakarta.apache.org/commons/transaction/"
+SRC_URI="mirror://apache/jakarta/commons/transaction/source/${P}-src.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/commons-codec
+ dev-java/jta
+ dev-java/log4j"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ dev-java/ant-core
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from commons-codec
+ java-pkg_jar-from log4j
+ java-pkg_jar-from jta
+}
+
+src_compile() {
+ local antflags="jar"
+ use doc && antflags="${antflags} javadocs"
+ eant ${antflags} jar || die "Compilation failed"
+}
+
+src_install() {
+ java-pkg_newjar dist/lib/${P}.jar ${PN}.jar
+
+ dodoc NOTICE.txt REAME.txt RELEASE-NOTES.txt
+ java-pkg_dohtml -r build/doc/* xdocs
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1 b/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1
index c352f68cd146..202726bf9a61 100644
--- a/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1
+++ b/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1
@@ -1 +1,3 @@
MD5 2ec968e144f84e8d0ab193757bd4e306 commons-transaction-1.0.1-src.tgz 849934
+RMD160 9852690c3a78fc9e4998cc99862553dbe0985f24 commons-transaction-1.0.1-src.tgz 849934
+SHA256 2840697b784ae544de00e3b4876b34a1cef2a869e17d0397cf2087fa5d0b8882 commons-transaction-1.0.1-src.tgz 849934
diff --git a/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1-r1 b/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1-r1
new file mode 100644
index 000000000000..202726bf9a61
--- /dev/null
+++ b/dev-java/commons-transaction/files/digest-commons-transaction-1.0.1-r1
@@ -0,0 +1,3 @@
+MD5 2ec968e144f84e8d0ab193757bd4e306 commons-transaction-1.0.1-src.tgz 849934
+RMD160 9852690c3a78fc9e4998cc99862553dbe0985f24 commons-transaction-1.0.1-src.tgz 849934
+SHA256 2840697b784ae544de00e3b4876b34a1cef2a869e17d0397cf2087fa5d0b8882 commons-transaction-1.0.1-src.tgz 849934