summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-04-06 08:04:04 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-04-06 08:04:04 +0000
commit1aefc166bf51d0227c25d97a3c13a03d31c5186a (patch)
tree59aad7e2bf4e483b13690ccfc2c196e617ad5cbe /dev-java/commons-pool
parentmoved x86 ppc sparc to stable. (diff)
downloadgentoo-2-1aefc166bf51d0227c25d97a3c13a03d31c5186a.tar.gz
gentoo-2-1aefc166bf51d0227c25d97a3c13a03d31c5186a.tar.bz2
gentoo-2-1aefc166bf51d0227c25d97a3c13a03d31c5186a.zip
moved x86 ppc sparc to stable; housekeeping on older builds.
Diffstat (limited to 'dev-java/commons-pool')
-rw-r--r--dev-java/commons-pool/ChangeLog7
-rw-r--r--dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild43
-rw-r--r--dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild4
-rw-r--r--dev-java/commons-pool/files/digest-commons-pool-1.0.1-r21
-rw-r--r--dev-java/commons-pool/files/digest-commons-pool-1.0.1-r31
5 files changed, 9 insertions, 47 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index 4849a14fb7a8..614f13e9ce6f 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-java/commons-pool
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.7 2003/03/22 12:36:06 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.8 2003/04/06 08:04:04 absinthe Exp $
*commons-pool-1.0.1-r3 (22 Mar 2003)
+ 06 Apr 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-pool-1.0.1-r2.ebuild, commons-pool-1.0.1-r2.ebuild,
+ commons-pool-1.0.1-r3.ebuild:
+ moved x86 ppc sparc to stable.
+
22 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
commons-pool-1.0.1-r3.ebuild:
Changed to use jakarta-commons eclass.
diff --git a/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild b/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild
deleted file mode 100644
index 3ac8bf9b76fe..000000000000
--- a/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild,v 1.5 2003/02/13 10:08:18 vapier Exp $
-
-S=${WORKDIR}/${PN}-${PV}-src
-DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
-HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
-SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- >=dev-java/commons-collections-2.0
- junit? ( >=junit-3.7 )"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/commons-collections-2.0"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="jikes junit"
-
-src_compile() {
- local myc
-
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if [ -n "`use junit`" ] ; then
- echo "junit.jar=`java-config --classpath=junit`" >> build.properties
- ANT_OPTS=${myc} ant || die "Testing Classes Failed"
- fi
-
- ANT_OPTS=${myc} ant dist-jar || die "Compilation Failed"
- ANT_OPTS=${myc} ant doc || die "Unable to create documents"
-}
-
-src_install () {
- dojar dist/${PN}*.jar || die "Unable to install"
- dodoc README.txt
- dohtml STATUS.html PROPOSAL.html
- dohtml -r dist/docs/*
-}
diff --git a/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild b/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
index a5e3c0a31a9d..873f69e70652 100644
--- a/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
+++ b/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild,v 1.1 2003/03/22 12:36:06 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild,v 1.2 2003/04/06 08:04:04 absinthe Exp $
inherit jakarta-commons
@@ -16,7 +16,7 @@ RDEPEND=">=virtual/jre-1.3
>=dev-java/commons-collections-2.0"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86 ppc sparc"
IUSE="doc jikes junit"
src_compile() {
diff --git a/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r2 b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r2
deleted file mode 100644
index 0532b13e26a7..000000000000
--- a/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 df9aaf5ee3e5d68abbee6eca0b8d037f commons-pool-1.0.1-src.tar.gz 62093
diff --git a/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3 b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3
index 0532b13e26a7..2899db62d6e2 100644
--- a/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3
+++ b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3
@@ -1 +1,2 @@
+MD5 d10bda76c34acc22ceadc431cf225855 /commons-pool-1.0.1-r3.ebuild 1078
MD5 df9aaf5ee3e5d68abbee6eca0b8d037f commons-pool-1.0.1-src.tar.gz 62093