summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:36:47 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:36:47 +0000
commitbc6f030fa6cca20acd14a41dc93285a0d28914d5 (patch)
tree8161c41189af7b2263423c29fe67d51b5035bcd3 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-bc6f030fa6cca20acd14a41dc93285a0d28914d5.tar.gz
gentoo-2-bc6f030fa6cca20acd14a41dc93285a0d28914d5.tar.bz2
gentoo-2-bc6f030fa6cca20acd14a41dc93285a0d28914d5.zip
Version bump.
(Portage version: 2.2.0_alpha149_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/ghc-paths/ChangeLog8
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild (renamed from dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild)22
2 files changed, 18 insertions, 12 deletions
diff --git a/dev-haskell/ghc-paths/ChangeLog b/dev-haskell/ghc-paths/ChangeLog
index 75db951853a1..a252053f48d9 100644
--- a/dev-haskell/ghc-paths/ChangeLog
+++ b/dev-haskell/ghc-paths/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/ghc-paths
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ChangeLog,v 1.7 2012/09/12 16:04:35 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ChangeLog,v 1.8 2012/12/22 21:36:47 slyfox Exp $
+
+*ghc-paths-0.1.0.9 (22 Dec 2012)
+
+ 22 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> +ghc-paths-0.1.0.9.ebuild,
+ -ghc-paths-0.1.0.8.ebuild:
+ Version bump.
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> ghc-paths-0.1.0.8.ebuild:
move dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild ebuild to mirror://hackage
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild
index b7c4b98ea35c..efeaf80810e2 100644
--- a/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild,v 1.3 2012/09/12 16:04:35 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild,v 1.1 2012/12/22 21:36:47 slyfox Exp $
-EAPI="3"
+EAPI=5
# haddock feature is explicitely disabled, as this library can be used as haddock depend
CABAL_FEATURES="lib profile"
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND=">=dev-lang/ghc-6.8.2"
+RDEPEND=">=dev-lang/ghc-6.8.2:="
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
@@ -33,15 +33,15 @@ src_prepare() {
# GHC_PATHS_GHC_PKG /usr/bin/ghc-pkg
# GHC_PATHS_GHC /usr/bin/ghc (be careful: GHC_PATHS_GHC is a substring of GHC_PATHS_GHC_PKG)
- cat >"${S}/GHC/Paths.hs" <<EOF
-module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
+ cat >"${S}/GHC/Paths.hs" <<-EOF
+ module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
-libdir, docdir, ghc, ghc_pkg :: FilePath
+ libdir, docdir, ghc, ghc_pkg :: FilePath
-libdir = "$(ghc-libdir)"
-docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
+ libdir = "$(ghc-libdir)"
+ docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
-ghc = "$(ghc-getghc)"
-ghc_pkg = "$(ghc-getghcpkg)"
-EOF
+ ghc = "$(ghc-getghc)"
+ ghc_pkg = "$(ghc-getghcpkg)"
+ EOF
}