summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 12:17:28 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 12:17:28 +0000
commit842fd6d5a2c57a724cfc63b8222b81d88ed41a5e (patch)
treeb267f1e389e5a5ac2dc508a4dc88f33546f49363 /dev-haskell
parentKeyword ~mips (diff)
downloadgentoo-2-842fd6d5a2c57a724cfc63b8222b81d88ed41a5e.tar.gz
gentoo-2-842fd6d5a2c57a724cfc63b8222b81d88ed41a5e.tar.bz2
gentoo-2-842fd6d5a2c57a724cfc63b8222b81d88ed41a5e.zip
Bump glut to 2.3.0.0, fixes bug #363979
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/glut/ChangeLog9
-rw-r--r--dev-haskell/glut/glut-2.3.0.0.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-haskell/glut/ChangeLog b/dev-haskell/glut/ChangeLog
index dd3f1e2d3d92..233349398926 100644
--- a/dev-haskell/glut/ChangeLog
+++ b/dev-haskell/glut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/glut
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/ChangeLog,v 1.13 2010/09/16 18:08:13 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/ChangeLog,v 1.14 2012/06/02 12:17:28 gienah Exp $
+
+*glut-2.3.0.0 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +glut-2.3.0.0.ebuild:
+ Bump glut to 2.3.0.0, fixes bug #363979
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> glut-2.1.1.1.ebuild,
glut-2.1.1.2.ebuild:
diff --git a/dev-haskell/glut/glut-2.3.0.0.ebuild b/dev-haskell/glut/glut-2.3.0.0.ebuild
new file mode 100644
index 000000000000..0485584fa577
--- /dev/null
+++ b/dev-haskell/glut/glut-2.3.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.3.0.0.ebuild,v 1.1 2012/06/02 12:17:28 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="GLUT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding for the OpenGL Utility Toolkit"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/opengl-2.5*[profile?]
+ =dev-haskell/openglraw-1.2*[profile?]
+ =dev-haskell/statevar-1.0*[profile?]
+ =dev-haskell/tensor-1.0*[profile?]
+ >=dev-lang/ghc-6.12.1
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"