summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-01-04 12:57:02 +0000
committerMark Wright <gienah@gentoo.org>2015-01-04 12:57:02 +0000
commit23f54e28411e81774301000b050684acdeb5ee46 (patch)
treea464f24a3a4f95698084f4d1bb003e824f184ae0 /dev-haskell
parentStabilize on alpha/amd64/ia64/ppc/ppc64/sparc/x86 (diff)
downloadgentoo-2-23f54e28411e81774301000b050684acdeb5ee46.tar.gz
gentoo-2-23f54e28411e81774301000b050684acdeb5ee46.tar.bz2
gentoo-2-23f54e28411e81774301000b050684acdeb5ee46.zip
Bump conduit-extra to 1.1.6.1, patched for ghc 7.10.1 RC1 https://github.com/snoyberg/conduit/pull/195
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/conduit-extra/ChangeLog11
-rw-r--r--dev-haskell/conduit-extra/conduit-extra-1.1.6.1.ebuild42
-rw-r--r--dev-haskell/conduit-extra/files/conduit-extra-1.1.6.1-ghc-7.10.patch8
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-haskell/conduit-extra/ChangeLog b/dev-haskell/conduit-extra/ChangeLog
index 40ab754747b8..95e895eb1004 100644
--- a/dev-haskell/conduit-extra/ChangeLog
+++ b/dev-haskell/conduit-extra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/conduit-extra
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit-extra/ChangeLog,v 1.5 2014/12/22 07:30:02 gienah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit-extra/ChangeLog,v 1.6 2015/01/04 12:57:02 gienah Exp $
+
+*conduit-extra-1.1.6.1 (04 Jan 2015)
+
+ 04 Jan 2015; Mark Wright <gienah@gentoo.org> +conduit-extra-1.1.6.1.ebuild,
+ +files/conduit-extra-1.1.6.1-ghc-7.10.patch:
+ Bump conduit-extra to 1.1.6.1, patched for ghc 7.10.1 RC1
+ https://github.com/snoyberg/conduit/pull/195
*conduit-extra-1.1.5.1 (22 Dec 2014)
diff --git a/dev-haskell/conduit-extra/conduit-extra-1.1.6.1.ebuild b/dev-haskell/conduit-extra/conduit-extra-1.1.6.1.ebuild
new file mode 100644
index 000000000000..76b755e9b04d
--- /dev/null
+++ b/dev-haskell/conduit-extra/conduit-extra-1.1.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit-extra/conduit-extra-1.1.6.1.ebuild,v 1.1 2015/01/04 12:57:02 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+DESCRIPTION="Batteries included conduit: adapters for common libraries"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/primitive-0.5:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.8:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ dev-haskell/exceptions
+ >=dev-haskell/hspec-1.3 )
+"
+
+PATCHES=("${FILESDIR}/${PN}-1.1.6.1-ghc-7.10.patch")
diff --git a/dev-haskell/conduit-extra/files/conduit-extra-1.1.6.1-ghc-7.10.patch b/dev-haskell/conduit-extra/files/conduit-extra-1.1.6.1-ghc-7.10.patch
new file mode 100644
index 000000000000..29768e902d0c
--- /dev/null
+++ b/dev-haskell/conduit-extra/files/conduit-extra-1.1.6.1-ghc-7.10.patch
@@ -0,0 +1,8 @@
+--- conduit-extra-1.1.6.1-orig/test/Data/Conduit/TextSpec.hs 2015-01-04 19:32:04.000000000 +1100
++++ conduit-extra-1.1.6.1/test/Data/Conduit/TextSpec.hs 2015-01-04 23:39:46.786637326 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE OverloadedStrings #-}
++{-# LANGUAGE FlexibleContexts, OverloadedStrings #-}
+ module Data.Conduit.TextSpec (spec) where
+
+ import qualified Data.Conduit.Text as CT