summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 15:20:37 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 15:20:37 +0000
commit21b813fbfee8275e757befed10745ceefe10b216 (patch)
tree43121311b106ef60925fa745a17c316407cf092a /dev-haskell
parentamd64/x86 stable, bug #266664 (diff)
downloadgentoo-2-21b813fbfee8275e757befed10745ceefe10b216.tar.gz
gentoo-2-21b813fbfee8275e757befed10745ceefe10b216.tar.bz2
gentoo-2-21b813fbfee8275e757befed10745ceefe10b216.zip
Version bump dev-haskell/haddock-2.4.2, currently masked for testing.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haddock/ChangeLog10
-rw-r--r--dev-haskell/haddock/haddock-2.4.2.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index daa3f1937748..06399c2a84fe 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haddock
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.56 2008/10/04 10:12:48 armin76 Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.57 2009/04/19 15:20:37 kolmodin Exp $
+
+*haddock-2.4.2 (19 Apr 2009)
+
+ 19 Apr 2009; Lennart Kolmodin <kolmodin@gentoo.org> +haddock-2.4.2.ebuild:
+ Version bump. Depends on dev-lang/ghc-6.10.2, so it's currently masked for
+ testing.
04 Oct 2008; Raúl Porcel <armin76@gentoo.org> haddock-0.8.ebuild:
alpha/ia64 stable
diff --git a/dev-haskell/haddock/haddock-2.4.2.ebuild b/dev-haskell/haddock/haddock-2.4.2.ebuild
new file mode 100644
index 000000000000..daf445c82833
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.2.ebuild,v 1.1 2009/04/19 15:20:37 kolmodin Exp $
+
+CABAL_FEATURES="bin lib"
+# don't enable profiling as the 'ghc' package is not built with profiling
+inherit haskell-cabal autotools
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="~dev-lang/ghc-6.10.2
+ dev-haskell/filepath
+ dev-haskell/ghc-paths"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+
+src_unpack() {
+ unpack ${A}
+
+ if use doc; then
+ cd "${S}/doc"
+ eautoreconf
+ fi
+
+}
+
+src_compile () {
+ cabal_src_compile
+ if use doc; then
+ cd "${S}/doc"
+ ./configure --prefix="${D}/usr/" \
+ || die 'error configuring documentation.'
+ emake html || die 'error building documentation.'
+ fi
+}
+
+src_install () {
+ cabal_src_install
+ if use doc; then
+ dohtml -r "${S}/doc/haddock/"*
+ fi
+ dodoc CHANGES README
+}
+