summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-05-19 05:13:17 +0000
committerJon Hood <squinky86@gentoo.org>2006-05-19 05:13:17 +0000
commit671940f83b6e42aa8ba3ed7d3384b3116fcc6729 (patch)
treeede982d223ecda4ca1166fffe3bb29ad083eb615 /dev-haskell/wxhaskell
parentStable on x86; bug #133570 (diff)
downloadgentoo-2-671940f83b6e42aa8ba3ed7d3384b3116fcc6729.tar.gz
gentoo-2-671940f83b6e42aa8ba3ed7d3384b3116fcc6729.tar.bz2
gentoo-2-671940f83b6e42aa8ba3ed7d3384b3116fcc6729.zip
multilib-strict lovin'
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'dev-haskell/wxhaskell')
-rw-r--r--dev-haskell/wxhaskell/ChangeLog6
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild18
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
index ce7ad1b5dbff..9453e9532ef8 100644
--- a/dev-haskell/wxhaskell/ChangeLog
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/wxhaskell
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.20 2006/03/11 11:50:30 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.21 2006/05/19 05:13:17 squinky86 Exp $
+
+ 19 May 2006; Jon Hood <squinky86@gentoo.org> wxhaskell-0.9.4.ebuild:
+ Use the correct libdirs when installing for 64-bit. This way, it compiles
+ with multilib-strict.
10 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> wxhaskell-0.9.4.ebuild:
Make the wxhaskell package be exposed by default with ghc-6.2.2
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
index ab41230b8067..14b5d976ff06 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild,v 1.5 2006/03/11 11:50:30 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild,v 1.6 2006/05/19 05:13:17 squinky86 Exp $
-inherit flag-o-matic wxwidgets ghc-package
+inherit flag-o-matic wxwidgets ghc-package multilib
DESCRIPTION="a portable and native GUI library for Haskell"
HOMEPAGE="http://wxhaskell.sourceforge.net/"
@@ -62,7 +62,7 @@ src_compile() {
--wx-config="${WX_CONFIG}" \
--prefix=/usr \
--with-opengl \
- --libdir=/usr/lib/${P} \
+ --libdir=/usr/$(get_libdir)/${P} \
--package-conf=${S}/$(ghc-localpkgconf) \
|| die "./configure failed"
@@ -81,9 +81,9 @@ src_install() {
emake -j1 install-files DESTDIR="${D}" || die "make install failed"
# the .so needs to be on the lib path
- mkdir -p ${D}/usr/lib
- for f in ${D}/usr/lib/${P}/libwxc-*.so; do
- mv ${f} ${D}/usr/lib/
+ mkdir -p ${D}/usr/$(get_libdir)
+ for f in ${D}/usr/$(get_libdir)/${P}/libwxc-*.so; do
+ mv ${f} ${D}/usr/$(get_libdir)/
done
if use doc; then
@@ -93,9 +93,9 @@ src_install() {
# substitute for the ${wxhlibdir} in package files and register them
# for ghc-6.2 change the package to be exposed by default.
- sed -i -e "s:\${wxhlibdir}:${D}/usr/lib/${P}:" \
+ sed -i -e "s:\${wxhlibdir}:${D}/usr/$(get_libdir)/${P}:" \
-e "s:auto = False:auto = True:" \
- ${D}/usr/lib/${P}/*.pkg
- ghc-setup-pkg ${D}/usr/lib/${P}/*.pkg
+ ${D}/usr/$(get_libdir)/${P}/*.pkg
+ ghc-setup-pkg ${D}/usr/$(get_libdir)/${P}/*.pkg
ghc-install-pkg
}