summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-25 06:01:41 +0000
committerMark Wright <gienah@gentoo.org>2012-11-25 06:01:41 +0000
commite7aee4d0e44a965f7f6a15f5bab06c258095dd36 (patch)
treeeef45401199fa11d044f677c982f7231f4e5656e /dev-haskell/hexpat
parentAdd list (diff)
downloadgentoo-2-e7aee4d0e44a965f7f6a15f5bab06c258095dd36.tar.gz
gentoo-2-e7aee4d0e44a965f7f6a15f5bab06c258095dd36.tar.bz2
gentoo-2-e7aee4d0e44a965f7f6a15f5bab06c258095dd36.zip
Add hexpat
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/hexpat')
-rw-r--r--dev-haskell/hexpat/ChangeLog9
-rw-r--r--dev-haskell/hexpat/hexpat-0.20.3.ebuild32
-rw-r--r--dev-haskell/hexpat/metadata.xml59
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-haskell/hexpat/ChangeLog b/dev-haskell/hexpat/ChangeLog
new file mode 100644
index 000000000000..ef730f33f0e4
--- /dev/null
+++ b/dev-haskell/hexpat/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/hexpat
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hexpat/ChangeLog,v 1.1 2012/11/25 06:01:41 gienah Exp $
+
+*hexpat-0.20.3 (25 Nov 2012)
+
+ 25 Nov 2012; Mark Wright <gienah@gentoo.org> +hexpat-0.20.3.ebuild,
+ +metadata.xml:
+ Add hexpat
diff --git a/dev-haskell/hexpat/hexpat-0.20.3.ebuild b/dev-haskell/hexpat/hexpat-0.20.3.ebuild
new file mode 100644
index 000000000000..6359b9843a78
--- /dev/null
+++ b/dev-haskell/hexpat/hexpat-0.20.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hexpat/hexpat-0.20.3.ebuild,v 1.1 2012/11/25 06:01:41 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="XML parser/formatter based on expat"
+HOMEPAGE="http://haskell.org/haskellwiki/Hexpat/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0:=[profile?]
+ <dev-haskell/deepseq-1.4.0.0:=[profile?]
+ =dev-haskell/extensible-exceptions-0.1*:=[profile?]
+ >=dev-haskell/list-0.4.2:=[profile?]
+ <dev-haskell/list-0.6:=[profile?]
+ >=dev-haskell/text-0.5:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ =dev-haskell/utf8-string-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/hexpat/metadata.xml b/dev-haskell/hexpat/metadata.xml
new file mode 100644
index 000000000000..5a916de16086
--- /dev/null
+++ b/dev-haskell/hexpat/metadata.xml
@@ -0,0 +1,59 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a general purpose Haskell XML library using Expat to
+ do its parsing (&lt;http://expat.sourceforge.net/&gt; - a fast stream-oriented XML
+ parser written in C). It is extensible to any string type, with @String@,
+ @ByteString@ and @Text@ provided out of the box.
+
+ Basic usage: Parsing a tree (/Tree/), formatting a tree (/Format/).
+ Other features: Helpers for processing XML trees (/Proc/), trees annotated with
+ XML source location (/Annotated/), extended XML trees with comments,
+ processing instructions, etc (/Extended/), XML cursors (/Cursor/),
+ SAX-style parse (/SAX/), and access to the low-level interface in case speed
+ is paramount (/Internal.IO/).
+
+ The design goals are speed, speed, speed, interface simplicity and modularity.
+
+ For introduction and examples, see the /Text.XML.Expat.Tree/ module. For benchmarks,
+ &lt;http://haskell.org/haskellwiki/Hexpat/&gt;
+
+ If you want to do interactive I\/O, an obvious option is to use lazy parsing
+ with one of the lazy I\/O functions such as hGetContents. However, this can be
+ problematic in some applications because it doesn&#39;t handle I\/O errors properly
+ and can give no guarantee of timely resource cleanup. In these cases, chunked
+ I\/O is a better approach: Take a look at the /hexpat-enumerator/ package.
+
+ /IO/ is filed under /Internal/ because it&#39;s low-level and most users won&#39;t want
+ it. The other /Internal/ modules are re-exported by /Annotated/, /Tree/ and /Extended/,
+ so you won&#39;t need to import them directly.
+
+ Credits to Iavor Diatchki and the @xml@ (XML.Light) package for /Proc/ and /Cursor/.
+ Thanks to the many contributors.
+
+ BOUND VS. UNBOUND THREADS: GHC (at least versions 6.12.X) will spawn threads
+ if you call a safe FFI callback from an unbound thread. This can get out of
+ control in a busy application. To avoid this, from version 0.19.1 we now delegate
+ processing to a single worker thread if the calling thread is not bound.
+ This essentially means that hexpat currently won&#39;t exploit multicores very well.
+ It also means that hexpat may be more efficient on threads spawned with forkOS
+ (to give you a bound thread) rather than forkIO.
+
+ ChangeLog: 0.15 changes intended to fix a (rare) \&quot;error: a C finalizer called back into Haskell.\&quot;
+ that seemed only to happen only on ghc6.12.X; 0.15.1 Fix broken Annotated parse;
+ 0.16 switch from mtl to transformers; 0.17 fix mapNodeContainer &amp; rename some things.;
+ 0.18 rename defaultEncoding to overrideEncoding. 0.18.3 formatG and indent were demanding list
+ items more than once (inefficient in chunked processing); 0.19 add Extended.hs;
+ 0.19.1 fix a memory leak introduced in 0.19, delegate parsing to bound thread
+ if unbound (see note above); 0.19.2 include expat source code so \&#39;cabal install\&#39; just works
+ on Linux, Mac and Windows (thanks Jacob Stanley); 0.19.3 fix misconfiguration of expat
+ which broke entity parsing; 0.19.4 bump version constraint for text; 0.19.5 bump text
+ to &lt; 0.12 and fix text-0.10.0.1 breakage; 0.19.6 dependency breakage with List;
+ 0.19.7 ghc-7.2.1 compatibility; 0.19.8 fix space leak on lazy parse under ghc-7.2.1
+ </longdescription>
+</pkgmetadata>