summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-18 14:25:39 +0000
committerMark Wright <gienah@gentoo.org>2012-06-18 14:25:39 +0000
commit01bf7604303b0ba262ef145b5b4339f9e220c060 (patch)
treec014b607b7bffae7525552d9122eb931b07f4fd9 /dev-haskell/haxml
parentChange license to MIT (diff)
downloadgentoo-2-01bf7604303b0ba262ef145b5b4339f9e220c060.tar.gz
gentoo-2-01bf7604303b0ba262ef145b5b4339f9e220c060.tar.bz2
gentoo-2-01bf7604303b0ba262ef145b5b4339f9e220c060.zip
Bump haxml to 1.23.2
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/haxml')
-rw-r--r--dev-haskell/haxml/ChangeLog8
-rw-r--r--dev-haskell/haxml/files/haxml-1.23.2-haddock.patch37
-rw-r--r--dev-haskell/haxml/haxml-1.23.2.ebuild32
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-haskell/haxml/ChangeLog b/dev-haskell/haxml/ChangeLog
index b87b4dff5844..7f19573e7bea 100644
--- a/dev-haskell/haxml/ChangeLog
+++ b/dev-haskell/haxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haxml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.30 2012/06/16 09:52:04 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.31 2012/06/18 14:25:39 gienah Exp $
+
+*haxml-1.23.2 (18 Jun 2012)
+
+ 18 Jun 2012; Mark Wright <gienah@gentoo.org>
+ +files/haxml-1.23.2-haddock.patch, +haxml-1.23.2.ebuild:
+ Bump haxml to 1.23.2
*haxml-1.23 (16 Jun 2012)
diff --git a/dev-haskell/haxml/files/haxml-1.23.2-haddock.patch b/dev-haskell/haxml/files/haxml-1.23.2-haddock.patch
new file mode 100644
index 000000000000..1020fb754e24
--- /dev/null
+++ b/dev-haskell/haxml/files/haxml-1.23.2-haddock.patch
@@ -0,0 +1,37 @@
+--- HaXml-1.23.2-orig/src/Text/XML/HaXml/Schema/HaskellTypeModel.hs 2012-06-18 23:17:57.000000000 +1000
++++ HaXml-1.23.2/src/Text/XML/HaXml/Schema/HaskellTypeModel.hs 2012-06-18 23:37:04.279978702 +1000
+@@ -77,8 +77,8 @@
+ -- rests with the input doc, not with the caller of the parser.
+ | ElementsAttrsAbstract {-typename-}XName
+ {-subtypes-}[(XName,Maybe XName)]
+- -- ^ [(type name, module where declared later)]
+ Comment
++ -- ^ [(type name, module where declared later)]
+
+ -- becomes function
+ -- elementE :: Parser T
+--- HaXml-1.23.2-orig/src/Text/XML/HaXml/Schema/PrettyHaskell.hs 2012-06-18 23:17:57.000000000 +1000
++++ HaXml-1.23.2/src/Text/XML/HaXml/Schema/PrettyHaskell.hs 2012-06-18 23:34:50.954660444 +1000
+@@ -403,9 +403,6 @@
+ $$ text "data" <+> ppUnqConId nx t
+ $$ nest 8 (ppvList "=" "|" "" ppAbstrCons insts
+ $$ text "deriving (Eq,Show)")
+--- $$ text "-- instance SchemaType" <+> ppUnqConId nx t
+--- <+> text "(declared in Instance module)"
+--- *** Declare instance here
+ $$ text "instance SchemaType" <+> ppUnqConId nx t <+> text "where"
+ $$ nest 4 (text "parseSchemaType s = do"
+ $$ nest 4 (vcat (intersperse (text "`onFail`")
+@@ -417,12 +414,6 @@
+ where
+ ppAbstrCons (name,Nothing) = con name <+> ppConId nx name
+ ppAbstrCons (name,Just mod) = con name <+> ppConId nx name
+--- *** Declare FwdDecl type here (proxy for type declared in later module)
+--- ppAbstrCons (name,Just mod) = text "forall q . (FwdDecl" <+>
+--- fwd name <+> text "q," <+>
+--- text "SchemaType q) =>" <+>
+--- con name <+>
+--- text "("<>fwd name<>text"->q)" <+> fwd name
+ ppParse (name,Nothing) = text "(fmap" <+> con name <+>
+ text "$ parseSchemaType s)"
+ ppParse (name,Just _) = ppParse (name,Nothing)
diff --git a/dev-haskell/haxml/haxml-1.23.2.ebuild b/dev-haskell/haxml/haxml-1.23.2.ebuild
new file mode 100644
index 000000000000..ae2914044b6e
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.23.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.23.2.ebuild,v 1.1 2012/06/18 14:25:39 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/HaXml/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.5[profile?]
+ dev-haskell/random[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-1.23.2-haddock.patch")