summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-09-14 13:00:49 +0000
committerMark Wright <gienah@gentoo.org>2012-09-14 13:00:49 +0000
commitce83fac85a6cb4345ff9d5162c1f0b735111a5b8 (patch)
tree254ec0521977ec1c46f0f4859ac0deb5df0252f2 /dev-haskell/happy
parentBump hunit to 1.2.5.1 (diff)
downloadgentoo-2-ce83fac85a6cb4345ff9d5162c1f0b735111a5b8.tar.gz
gentoo-2-ce83fac85a6cb4345ff9d5162c1f0b735111a5b8.tar.bz2
gentoo-2-ce83fac85a6cb4345ff9d5162c1f0b735111a5b8.zip
Patch happy 1.18.9 build for ghc 7.6.1
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/happy')
-rw-r--r--dev-haskell/happy/ChangeLog6
-rw-r--r--dev-haskell/happy/files/happy-1.18.9-ghc-7.5.patch20
-rw-r--r--dev-haskell/happy/happy-1.18.9.ebuild12
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index 91d35f44aa31..579884bb5361 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/happy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.59 2012/09/14 07:06:28 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.60 2012/09/14 13:00:49 gienah Exp $
+
+ 14 Sep 2012; Mark Wright <gienah@gentoo.org>
+ +files/happy-1.18.9-ghc-7.5.patch, happy-1.18.9.ebuild:
+ Patch happy 1.18.9 build for ghc 7.6.1
14 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> happy-1.18.2.ebuild,
happy-1.18.4.ebuild, happy-1.18.6.ebuild, happy-1.18.9.ebuild:
diff --git a/dev-haskell/happy/files/happy-1.18.9-ghc-7.5.patch b/dev-haskell/happy/files/happy-1.18.9-ghc-7.5.patch
new file mode 100644
index 000000000000..7c71048b3627
--- /dev/null
+++ b/dev-haskell/happy/files/happy-1.18.9-ghc-7.5.patch
@@ -0,0 +1,20 @@
+--- happy-1.18.9-orig/Setup.lhs 2012-02-06 20:49:56.000000000 +1100
++++ happy-1.18.9/Setup.lhs 2012-06-25 08:55:56.283147498 +1000
+@@ -10,7 +10,7 @@
+ import Distribution.Simple.Program
+
+ import System.FilePath ((</>))
+-import System.IO.Error ( try )
++import System.IO.Error ( tryIOError )
+ import System.Directory (removeFile)
+
+ main :: IO ()
+@@ -50,7 +50,7 @@
+ [ cpp_template "GLR_Base.hs" dst opts | (dst,opts) <- glr_base_templates ] ++
+ [ cpp_template "GLR_Lib.hs" dst opts | (dst,opts) <- glr_templates ])
+
+-myPostClean _ _ _ _ = mapM_ (try . removeFile) all_template_files
++myPostClean _ _ _ _ = mapM_ (tryIOError . removeFile) all_template_files
+
+ myInstall pkg_descr lbi hooks flags =
+ instHook defaultUserHooks pkg_descr' lbi hooks flags
diff --git a/dev-haskell/happy/happy-1.18.9.ebuild b/dev-haskell/happy/happy-1.18.9.ebuild
index 4496ee163c54..289ad7a70502 100644
--- a/dev-haskell/happy/happy-1.18.9.ebuild
+++ b/dev-haskell/happy/happy-1.18.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.9.ebuild,v 1.7 2012/09/14 07:06:28 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.9.ebuild,v 1.8 2012/09/14 13:00:49 gienah Exp $
# ebuild generated by hackport 0.2.9
EAPI="4"
CABAL_FEATURES="bin"
-inherit base haskell-cabal autotools
+inherit base eutils haskell-cabal autotools
DESCRIPTION="Happy is a parser generator for Haskell"
HOMEPAGE="http://www.haskell.org/happy/"
@@ -32,6 +32,14 @@ PATCHES=("${FILESDIR}/${PN}-1.18.6-man.patch"
src_prepare() {
base_src_prepare
+ # ghc 7.5 removed System.IO.try and Control.OldException.
+ # Conditional patch is required, as it is to the file Setup.lhs, so can not
+ # use LANGUAGE: CPP, and ghc 6.10.4 and 6.12.3 do not have
+ # System.IO.Error.tryIOError.
+ if has_version ">=dev-lang/ghc-7.5"; then
+ epatch "${FILESDIR}/${PN}-1.18.9-ghc-7.5.patch"
+ fi
+
use doc && cd doc && eautoconf
}