summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-02-08 21:04:47 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-02-08 21:04:47 +0000
commit24b52260bbc43f3d0916ecf6d5e708c7f796c6b7 (patch)
treec72a9762ba1a0667ad0d4cc9be82b5056bdb1391 /dev-haskell/alex
parentRemove mask on openoffice 3.0.1, see bug #258059 (diff)
downloadgentoo-2-24b52260bbc43f3d0916ecf6d5e708c7f796c6b7.tar.gz
gentoo-2-24b52260bbc43f3d0916ecf6d5e708c7f796c6b7.tar.bz2
gentoo-2-24b52260bbc43f3d0916ecf6d5e708c7f796c6b7.zip
Version bump dev-haskell/alex
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'dev-haskell/alex')
-rw-r--r--dev-haskell/alex/ChangeLog9
-rw-r--r--dev-haskell/alex/alex-2.3.1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-haskell/alex/ChangeLog b/dev-haskell/alex/ChangeLog
index cbd2ace03bcc..67002dd329c2 100644
--- a/dev-haskell/alex/ChangeLog
+++ b/dev-haskell/alex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/alex
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/alex/ChangeLog,v 1.35 2008/01/26 20:24:10 dcoutts Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/alex/ChangeLog,v 1.36 2009/02/08 21:04:47 kolmodin Exp $
+
+*alex-2.3.1 (08 Feb 2009)
+
+ 08 Feb 2009; Lennart Kolmodin <kolmodin@gentoo.org> +alex-2.3.1.ebuild:
+ Version bump, works with cabal-1.6
26 Jan 2008; Duncan Coutts <dcoutts@gentoo.org> -alex-2.0.1-r1.ebuild,
alex-2.1.0.ebuild, alex-2.2.ebuild:
diff --git a/dev-haskell/alex/alex-2.3.1.ebuild b/dev-haskell/alex/alex-2.3.1.ebuild
new file mode 100644
index 000000000000..b63538588312
--- /dev/null
+++ b/dev-haskell/alex/alex-2.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/alex/alex-2.3.1.ebuild,v 1.1 2009/02/08 21:04:47 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+inherit autotools haskell-cabal
+
+DESCRIPTION="Alex is a tool for generating lexical analysers in Haskell"
+HOMEPAGE="http://www.haskell.org/alex/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+# has worked with ppc64 too, but no ghc availably at the moment
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.2
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ if use doc; then
+ cd "${S}/doc/"
+ eautoreconf || die "eautoreconf for docs failed"
+ fi
+}
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ cd "${S}/doc/"
+ econf || die "econf for docs failed"
+ emake -j1 || die "emake for docs failed"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ if use doc; then
+ doman "${S}/doc/alex.1"
+ dohtml -r "${S}/doc/alex/"
+ fi
+ dodoc README
+}