summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-07-30 21:09:09 +0000
committerZac Medico <zmedico@gentoo.org>2015-07-30 21:09:09 +0000
commitdf8a508e9159782fdeaf132645c584be114edf98 (patch)
tree1691a13495bc4cc1a34c75b4056c47ce0f0694bf /dev-go
parentVersion bump, drop old (diff)
downloadgentoo-2-df8a508e9159782fdeaf132645c584be114edf98.tar.gz
gentoo-2-df8a508e9159782fdeaf132645c584be114edf98.tar.bz2
gentoo-2-df8a508e9159782fdeaf132645c584be114edf98.zip
Add go-eapache-queue.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-eapache-queue/ChangeLog10
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild58
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild58
-rw-r--r--dev-go/go-eapache-queue/metadata.xml10
4 files changed, 136 insertions, 0 deletions
diff --git a/dev-go/go-eapache-queue/ChangeLog b/dev-go/go-eapache-queue/ChangeLog
new file mode 100644
index 000000000000..6f6393237dde
--- /dev/null
+++ b/dev-go/go-eapache-queue/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-go/go-eapache-queue
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/ChangeLog,v 1.1 2015/07/30 21:09:09 zmedico Exp $
+
+*go-eapache-queue-1.0.2 (30 Jul 2015)
+*go-eapache-queue-9999 (30 Jul 2015)
+
+ 30 Jul 2015; Zac Medico <zmedico@gentoo.org> +go-eapache-queue-1.0.2.ebuild,
+ +go-eapache-queue-9999.ebuild, +metadata.xml:
+ Add go-eapache-queue.
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
new file mode 100644
index 000000000000..370b7447bfab
--- /dev/null
+++ b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild,v 1.1 2015/07/30 21:09:09 zmedico Exp $
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/queue
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Fast golang queue using ring-buffer"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
new file mode 100644
index 000000000000..f2b7757cfb1b
--- /dev/null
+++ b/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild,v 1.1 2015/07/30 21:09:09 zmedico Exp $
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/queue
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Fast golang queue using ring-buffer"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-eapache-queue/metadata.xml b/dev-go/go-eapache-queue/metadata.xml
new file mode 100644
index 000000000000..25e9450f7070
--- /dev/null
+++ b/dev-go/go-eapache-queue/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eapache/queue</remote-id>
+ </upstream>
+</pkgmetadata>