summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-07-30 20:31:56 +0000
committerZac Medico <zmedico@gentoo.org>2015-07-30 20:31:56 +0000
commit900b4cf3aa939de4245ac92c2b49d85337313874 (patch)
treec05a6f1563f7cb7f4378f2e26c2ed77d7bb2841d /dev-go
parentfixed typo made yesterday when adding the epatch line to fix hppa builds; bug... (diff)
downloadgentoo-2-900b4cf3aa939de4245ac92c2b49d85337313874.tar.gz
gentoo-2-900b4cf3aa939de4245ac92c2b49d85337313874.tar.bz2
gentoo-2-900b4cf3aa939de4245ac92c2b49d85337313874.zip
Add go-spew.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-spew/ChangeLog10
-rw-r--r--dev-go/go-spew/go-spew-0_pre20150619.ebuild60
-rw-r--r--dev-go/go-spew/go-spew-9999.ebuild60
-rw-r--r--dev-go/go-spew/metadata.xml10
4 files changed, 140 insertions, 0 deletions
diff --git a/dev-go/go-spew/ChangeLog b/dev-go/go-spew/ChangeLog
new file mode 100644
index 000000000000..17a054611adb
--- /dev/null
+++ b/dev-go/go-spew/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-go/go-spew
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/ChangeLog,v 1.1 2015/07/30 20:31:56 zmedico Exp $
+
+*go-spew-9999 (30 Jul 2015)
+*go-spew-0_pre20150619 (30 Jul 2015)
+
+ 30 Jul 2015; Zac Medico <zmedico@gentoo.org> +go-spew-0_pre20150619.ebuild,
+ +go-spew-9999.ebuild, +metadata.xml:
+ Add go-spew.
diff --git a/dev-go/go-spew/go-spew-0_pre20150619.ebuild b/dev-go/go-spew/go-spew-0_pre20150619.ebuild
new file mode 100644
index 000000000000..c0956ea90d00
--- /dev/null
+++ b/dev-go/go-spew/go-spew-0_pre20150619.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/go-spew-0_pre20150619.ebuild,v 1.1 2015/07/30 20:31:56 zmedico Exp $
+
+EAPI=5
+
+EGO_SRC=github.com/davecgh/${PN}
+EGO_PN=${EGO_SRC}/...
+
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="2df174808ee097f90d259e432cc04442cf60be21"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Implements a deep pretty printer for Go data structures to aid in debugging"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="ISC"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-spew/go-spew-9999.ebuild b/dev-go/go-spew/go-spew-9999.ebuild
new file mode 100644
index 000000000000..d168172809ab
--- /dev/null
+++ b/dev-go/go-spew/go-spew-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/go-spew-9999.ebuild,v 1.1 2015/07/30 20:31:56 zmedico Exp $
+
+EAPI=5
+
+EGO_SRC=github.com/davecgh/${PN}
+EGO_PN=${EGO_SRC}/...
+
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="2df174808ee097f90d259e432cc04442cf60be21"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Implements a deep pretty printer for Go data structures to aid in debugging"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="ISC"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-spew/metadata.xml b/dev-go/go-spew/metadata.xml
new file mode 100644
index 000000000000..d2c2e9307d05
--- /dev/null
+++ b/dev-go/go-spew/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">davecgh/go-spew</remote-id>
+ </upstream>
+</pkgmetadata>