summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-09-26 08:11:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-09-26 08:11:18 +0000
commit51b92a08fda1ec49eb34910773b12a5c8f22e546 (patch)
treeb004759b4d3599d12bae436913cdeb795f558235 /dev-games
parentUpdate for libpng 1.5 changes (closes bug #384263). (diff)
downloadgentoo-2-51b92a08fda1ec49eb34910773b12a5c8f22e546.tar.gz
gentoo-2-51b92a08fda1ec49eb34910773b12a5c8f22e546.tar.bz2
gentoo-2-51b92a08fda1ec49eb34910773b12a5c8f22e546.zip
Version bump to 0.3.11 Bug #383413
(Portage version: 2.1.10.19/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/wfmath/ChangeLog7
-rw-r--r--dev-games/wfmath/wfmath-0.3.11.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-games/wfmath/ChangeLog b/dev-games/wfmath/ChangeLog
index 108224e48719..aa1d11cd1592 100644
--- a/dev-games/wfmath/ChangeLog
+++ b/dev-games/wfmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/wfmath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.16 2011/01/16 04:11:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.17 2011/09/26 08:11:18 tupone Exp $
+
+*wfmath-0.3.11 (26 Sep 2011)
+
+ 26 Sep 2011; Tupone Alfredo <tupone@gentoo.org> +wfmath-0.3.11.ebuild:
+ Version bump to 0.3.11 Bug #383413 by Mr. Anderson
16 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> wfmath-0.3.10.ebuild:
add static-libs support
diff --git a/dev-games/wfmath/wfmath-0.3.11.ebuild b/dev-games/wfmath/wfmath-0.3.11.ebuild
new file mode 100644
index 000000000000..d41a66ae4338
--- /dev/null
+++ b/dev-games/wfmath/wfmath-0.3.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.11.ebuild,v 1.1 2011/09/26 08:11:18 tupone Exp $
+
+EAPI=2
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake -C doc docs || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ if use doc; then
+ dohtml doc/html/*
+ fi
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+}