summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-29 23:20:15 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-29 23:20:15 +0000
commit502eda4210b29b7d8b11f35b1bf714a2f3cdf6f8 (patch)
treeb93ab84ccf1c59737f04e20bcfa224211f5660b8 /dev-games
parentFix manifest. (diff)
downloadgentoo-2-502eda4210b29b7d8b11f35b1bf714a2f3cdf6f8.tar.gz
gentoo-2-502eda4210b29b7d8b11f35b1bf714a2f3cdf6f8.tar.bz2
gentoo-2-502eda4210b29b7d8b11f35b1bf714a2f3cdf6f8.zip
fix build with mesa-10.x wrt #496356
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/irrlicht/ChangeLog9
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.8-mesa-10.x.patch40
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.8.1-mesa-10.x.patch40
-rw-r--r--dev-games/irrlicht/irrlicht-1.8-r2.ebuild7
-rw-r--r--dev-games/irrlicht/irrlicht-1.8.1.ebuild7
5 files changed, 95 insertions, 8 deletions
diff --git a/dev-games/irrlicht/ChangeLog b/dev-games/irrlicht/ChangeLog
index 9bdd2b1ea195..8c5f2ff066e1 100644
--- a/dev-games/irrlicht/ChangeLog
+++ b/dev-games/irrlicht/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/irrlicht
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.69 2013/11/21 21:44:14 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.70 2014/04/29 23:20:15 hasufell Exp $
+
+ 29 Apr 2014; Julian Ospald <hasufell@gentoo.org> irrlicht-1.8-r2.ebuild,
+ irrlicht-1.8.1.ebuild, +files/irrlicht-1.8-mesa-10.x.patch,
+ +files/irrlicht-1.8.1-mesa-10.x.patch:
+ fix build with mesa-10.x wrt #496356
*irrlicht-1.8.1 (21 Nov 2013)
diff --git a/dev-games/irrlicht/files/irrlicht-1.8-mesa-10.x.patch b/dev-games/irrlicht/files/irrlicht-1.8-mesa-10.x.patch
new file mode 100644
index 000000000000..e90ff36443a0
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.8-mesa-10.x.patch
@@ -0,0 +1,40 @@
+From 244d00280c1b082ca164f92337773e9e4e1a3898 Mon Sep 17 00:00:00 2001
+From: hiker <henrichsjoerg@mgail.com>
+Date: Wed, 26 Feb 2014 11:13:03 +1100
+Subject: [PATCH] Applied patch from jpirie for fixing mesa 10 compilation
+ problems.
+
+--- irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
++++ irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
+@@ -21,6 +21,7 @@
+ #endif
+ #include <GL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #include "wglext.h"
+@@ -35,6 +36,7 @@
+ #endif
+ #include <OpenGL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #elif defined(_IRR_COMPILE_WITH_SDL_DEVICE_) && !defined(_IRR_COMPILE_WITH_X11_DEVICE_)
+@@ -48,6 +50,7 @@
+ #define NO_SDL_GLEXT
+ #include <SDL/SDL_video.h>
+ #include <SDL/SDL_opengl.h>
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #else
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+@@ -60,6 +63,7 @@
+ #include <GL/gl.h>
+ #include <GL/glx.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #undef GLX_ARB_get_proc_address // avoid problems with local glxext.h
+ #include "glxext.h"
diff --git a/dev-games/irrlicht/files/irrlicht-1.8.1-mesa-10.x.patch b/dev-games/irrlicht/files/irrlicht-1.8.1-mesa-10.x.patch
new file mode 100644
index 000000000000..e90ff36443a0
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.8.1-mesa-10.x.patch
@@ -0,0 +1,40 @@
+From 244d00280c1b082ca164f92337773e9e4e1a3898 Mon Sep 17 00:00:00 2001
+From: hiker <henrichsjoerg@mgail.com>
+Date: Wed, 26 Feb 2014 11:13:03 +1100
+Subject: [PATCH] Applied patch from jpirie for fixing mesa 10 compilation
+ problems.
+
+--- irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
++++ irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
+@@ -21,6 +21,7 @@
+ #endif
+ #include <GL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #include "wglext.h"
+@@ -35,6 +36,7 @@
+ #endif
+ #include <OpenGL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #elif defined(_IRR_COMPILE_WITH_SDL_DEVICE_) && !defined(_IRR_COMPILE_WITH_X11_DEVICE_)
+@@ -48,6 +50,7 @@
+ #define NO_SDL_GLEXT
+ #include <SDL/SDL_video.h>
+ #include <SDL/SDL_opengl.h>
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #else
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+@@ -60,6 +63,7 @@
+ #include <GL/gl.h>
+ #include <GL/glx.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #undef GLX_ARB_get_proc_address // avoid problems with local glxext.h
+ #include "glxext.h"
diff --git a/dev-games/irrlicht/irrlicht-1.8-r2.ebuild b/dev-games/irrlicht/irrlicht-1.8-r2.ebuild
index fb235fdd5abb..003f0d045431 100644
--- a/dev-games/irrlicht/irrlicht-1.8-r2.ebuild
+++ b/dev-games/irrlicht/irrlicht-1.8-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.8-r2.ebuild,v 1.5 2013/03/08 00:00:45 vincent Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.8-r2.ebuild,v 1.6 2014/04/29 23:20:15 hasufell Exp $
EAPI=5
inherit eutils multilib toolchain-funcs
@@ -35,7 +35,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PF}-gentoo.patch \
"${FILESDIR}"/${P}-config.patch \
- "${FILESDIR}"/${P}-demoMake.patch
+ "${FILESDIR}"/${P}-demoMake.patch \
+ "${FILESDIR}"/${P}-mesa-10.x.patch
sed -i \
-e 's:\.\./\.\./media:../media:g' \
diff --git a/dev-games/irrlicht/irrlicht-1.8.1.ebuild b/dev-games/irrlicht/irrlicht-1.8.1.ebuild
index 5b17c8fd31ee..87fcacef0998 100644
--- a/dev-games/irrlicht/irrlicht-1.8.1.ebuild
+++ b/dev-games/irrlicht/irrlicht-1.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.8.1.ebuild,v 1.1 2013/11/21 21:44:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.8.1.ebuild,v 1.2 2014/04/29 23:20:15 hasufell Exp $
EAPI=5
inherit eutils multilib toolchain-funcs
@@ -35,7 +35,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-config.patch \
- "${FILESDIR}"/${P}-demoMake.patch
+ "${FILESDIR}"/${P}-demoMake.patch \
+ "${FILESDIR}"/${P}-mesa-10.x.patch
sed -i \
-e 's:\.\./\.\./media:../media:g' \