summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-09 06:06:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-09 06:06:33 +0000
commit4a6d212dc6919a0147adeb794a1bfa47c67b06cd (patch)
tree8bb5785c452ad408195bc9febf57d9d3b9db19bb /dev-games
parentadd use deps for libsdl (diff)
downloadgentoo-2-4a6d212dc6919a0147adeb794a1bfa47c67b06cd.tar.gz
gentoo-2-4a6d212dc6919a0147adeb794a1bfa47c67b06cd.tar.bz2
gentoo-2-4a6d212dc6919a0147adeb794a1bfa47c67b06cd.zip
Fix building with libpng14.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog6
-rw-r--r--dev-games/crystalspace/crystalspace-1.2.1.ebuild6
-rw-r--r--dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch14
3 files changed, 23 insertions, 3 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 5aba7c2802e5..d413c80a8238 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/crystalspace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.39 2010/02/22 12:40:28 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.40 2010/03/09 06:06:32 ssuominen Exp $
+
+ 09 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ crystalspace-1.2.1.ebuild, +files/crystalspace-1.2.1-libpng14.patch:
+ Fix building with libpng14.
22 Feb 2010; Tupone Alfredo <tupone@gentoo.org> crystalspace-1.0.1.ebuild,
crystalspace-1.2.1.ebuild:
diff --git a/dev-games/crystalspace/crystalspace-1.2.1.ebuild b/dev-games/crystalspace/crystalspace-1.2.1.ebuild
index 833602b5f327..61fc607a0649 100644
--- a/dev-games/crystalspace/crystalspace-1.2.1.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.2.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.2.1.ebuild,v 1.2 2010/02/22 12:40:28 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.2.1.ebuild,v 1.3 2010/03/09 06:06:32 ssuominen Exp $
EAPI=2
-inherit flag-o-matic multilib wxwidgets
+inherit eutils flag-o-matic multilib wxwidgets
MY_P=${PN}-src-${PV}
DESCRIPTION="Portable 3D Game Development Kit written in C++"
@@ -51,6 +51,8 @@ src_prepare() {
Jamfile.in \
docs/Jamfile \
|| die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-libpng14.patch
}
src_configure() {
diff --git a/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch b/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch
new file mode 100644
index 000000000000..cb7998115a5b
--- /dev/null
+++ b/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch
@@ -0,0 +1,14 @@
+http://permalink.gmane.org/gmane.comp.graphics.crystalspace.tracker/5630
+http://www.libpng.org/pub/png/src/libpng-1.2.x-to-1.4.x-summary.txt
+
+--- plugins/video/loader/png/pngimage.cpp
++++ plugins/video/loader/png/pngimage.cpp
+@@ -378,7 +378,7 @@
+ const png_bytep iBuffer = dataSource->GetUint8();
+ const size_t iSize = dataSource->GetSize();
+
+- if (!png_check_sig (iBuffer, (int)iSize))
++ if (png_sig_cmp (iBuffer, 0, (int)iSize))
+ return false;
+ png = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ if (!png)