summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 01:51:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 01:51:48 +0000
commit5cded9c66be332e36b84ed616f5bf6bbadf0c9cc (patch)
tree2e9be68ea2a069546ab5e3ef436964f6196889e1 /dev-games/libnw
parentclean up (diff)
downloadgentoo-2-5cded9c66be332e36b84ed616f5bf6bbadf0c9cc.tar.gz
gentoo-2-5cded9c66be332e36b84ed616f5bf6bbadf0c9cc.tar.bz2
gentoo-2-5cded9c66be332e36b84ed616f5bf6bbadf0c9cc.zip
EAPI=2; respect CC
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'dev-games/libnw')
-rw-r--r--dev-games/libnw/ChangeLog7
-rw-r--r--dev-games/libnw/libnw-1.30.02.ebuild16
2 files changed, 19 insertions, 4 deletions
diff --git a/dev-games/libnw/ChangeLog b/dev-games/libnw/ChangeLog
index 54a45b35c9e9..94978c4e8a4b 100644
--- a/dev-games/libnw/ChangeLog
+++ b/dev-games/libnw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/libnw
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/libnw/ChangeLog,v 1.8 2008/09/05 13:18:22 nyhm Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/libnw/ChangeLog,v 1.9 2009/01/29 01:51:48 mr_bones_ Exp $
+
+ 29 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> libnw-1.30.02.ebuild:
+ EAPI=2; respect CC
*libnw-1.30.02 (05 Sep 2008)
diff --git a/dev-games/libnw/libnw-1.30.02.ebuild b/dev-games/libnw/libnw-1.30.02.ebuild
index 47e39f13598e..3540e7aefebc 100644
--- a/dev-games/libnw/libnw-1.30.02.ebuild
+++ b/dev-games/libnw/libnw-1.30.02.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/libnw/libnw-1.30.02.ebuild,v 1.1 2008/09/05 13:18:22 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/libnw/libnw-1.30.02.ebuild,v 1.2 2009/01/29 01:51:48 mr_bones_ Exp $
+
+EAPI=2
+inherit toolchain-funcs
DESCRIPTION="Tools and libraries for NWN file manipulation"
HOMEPAGE="http://openknights.sourceforge.net/"
@@ -15,6 +18,15 @@ DEPEND="sys-devel/bison
sys-devel/flex"
RDEPEND=""
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CXX =/d' \
+ $(find . -name Makefile.in) \
+ || die "sed failed"
+ tc-export CC CXX
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README README.tech TODO