summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-05-21 20:18:45 +0000
committerPeter Johanson <latexer@gentoo.org>2004-05-21 20:18:45 +0000
commit6487ef9179c4a49c214de05cc45bd78b65b48dd5 (patch)
treed58809b7b717209857ca81707b80d380e199b488 /dev-dotnet/xsp/xsp-0.13.ebuild
parentadd in vim 6.3b beta (diff)
downloadgentoo-2-6487ef9179c4a49c214de05cc45bd78b65b48dd5.tar.gz
gentoo-2-6487ef9179c4a49c214de05cc45bd78b65b48dd5.tar.bz2
gentoo-2-6487ef9179c4a49c214de05cc45bd78b65b48dd5.zip
Initial commit. Thanks to every on bug #41652 for the ebuilds, script, etc.
Diffstat (limited to 'dev-dotnet/xsp/xsp-0.13.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-0.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-0.13.ebuild b/dev-dotnet/xsp/xsp-0.13.ebuild
new file mode 100644
index 000000000000..160aa03a718c
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-0.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-0.13.ebuild,v 1.1 2004/05/21 20:18:45 latexer Exp $
+
+inherit mono
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/archive/beta1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=dev-dotnet/mono-0.91"
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake || die "make failed"
+}
+
+src_install() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 /bin/false /tmp aspnet
+
+ einstall DESTDIR=${D} || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xsp.initd xsp
+ insinto /etc/conf.d ; newins ${FILESDIR}/xsp.confd xsp
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}