summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-09 10:34:45 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-09 10:34:45 +0000
commitff3f4b094dd50ce2f037f3b3951356fb0eae7310 (patch)
tree45041fc0bed1576d2509ad13374dced9b41f2f3b /dev-db
parentVersion bump, fixing bug 528582. (diff)
downloadgentoo-2-ff3f4b094dd50ce2f037f3b3951356fb0eae7310.tar.gz
gentoo-2-ff3f4b094dd50ce2f037f3b3951356fb0eae7310.tar.bz2
gentoo-2-ff3f4b094dd50ce2f037f3b3951356fb0eae7310.zip
Version bump.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/vsqlite++/ChangeLog9
-rw-r--r--dev-db/vsqlite++/vsqlite++-0.3.13.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-db/vsqlite++/ChangeLog b/dev-db/vsqlite++/ChangeLog
index 2dfd7c375668..dcb4289c8187 100644
--- a/dev-db/vsqlite++/ChangeLog
+++ b/dev-db/vsqlite++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/vsqlite++
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/vsqlite++/ChangeLog,v 1.1 2013/10/19 13:30:00 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/vsqlite++/ChangeLog,v 1.2 2014/11/09 10:34:45 graaff Exp $
+
+*vsqlite++-0.3.13 (09 Nov 2014)
+
+ 09 Nov 2014; Hans de Graaff <graaff@gentoo.org> +vsqlite++-0.3.13.ebuild:
+ Version bump.
*vsqlite++-0.3.12 (19 Oct 2013)
diff --git a/dev-db/vsqlite++/vsqlite++-0.3.13.ebuild b/dev-db/vsqlite++/vsqlite++-0.3.13.ebuild
new file mode 100644
index 000000000000..1913a9d3f6f9
--- /dev/null
+++ b/dev-db/vsqlite++/vsqlite++-0.3.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/vsqlite++/vsqlite++-0.3.13.ebuild,v 1.1 2014/11/09 10:34:45 graaff Exp $
+
+EAPI=5
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="VSQLite++ - A welldesigned and portable SQLite3 Wrapper for C++"
+HOMEPAGE="http://evilissimo.fedorapeople.org/releases/vsqlite--/"
+SRC_URI="https://github.com/vinzenz/vsqlite--/archive/${PV}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/boost-1.33.1"
+
+RDEPEND="${DEPEND}
+ dev-db/sqlite:3"
+
+DOCS=(AUTHORS COPYING ChangeLog INSTALL NEWS README TODO VERSION)
+
+# package name is vsqlite++, but github / homepage name is vsqlite--
+S="${WORKDIR}/vsqlite---${PV}"
+
+src_prepare() {
+ ## remove O3 in AM_CXXFLAGS
+ sed -i -e 's/-O3//' Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}