summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-09 19:49:14 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-09 19:49:14 +0000
commitdedb623516be91f5f33ab4e2bac2b11e99fb12ac (patch)
tree7989769581659b3d1ca92d0a27862f7656fa58fd /dev-db
parentRemasking to avoid dependence on unstable MySQL 4 (diff)
downloadgentoo-2-dedb623516be91f5f33ab4e2bac2b11e99fb12ac.tar.gz
gentoo-2-dedb623516be91f5f33ab4e2bac2b11e99fb12ac.tar.bz2
gentoo-2-dedb623516be91f5f33ab4e2bac2b11e99fb12ac.zip
added fix for bug #15099 thanks to dragon
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog7
-rw-r--r--dev-db/mysql/files/digest-mysql-4.0.11a-r11
-rw-r--r--dev-db/mysql/mysql-4.0.11a-r1.ebuild187
3 files changed, 194 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 4c29970589f0..d04214ea273e 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.40 2003/03/05 00:17:43 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.41 2003/03/09 19:49:14 method Exp $
+
+*mysql-4.0.11a-r1 (09 Mar 2003)
+
+ 09 Mar 2003; Joshua Brindle <method@gentoo.org> mysql-4.0.11a-r1.ebuild:
+ bug fix for #15099 thanks to dragon
*mysql-3.23.54a-r1 (04 Mar 2003)
diff --git a/dev-db/mysql/files/digest-mysql-4.0.11a-r1 b/dev-db/mysql/files/digest-mysql-4.0.11a-r1
new file mode 100644
index 000000000000..4be9f2aaf89f
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-4.0.11a-r1
@@ -0,0 +1 @@
+MD5 dbe1426ed5ae1626b2b1a3ebca568200 mysql-4.0.11a-gamma.tar.gz 12317114
diff --git a/dev-db/mysql/mysql-4.0.11a-r1.ebuild b/dev-db/mysql/mysql-4.0.11a-r1.ebuild
new file mode 100644
index 000000000000..83822d3d3475
--- /dev/null
+++ b/dev-db/mysql/mysql-4.0.11a-r1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.11a-r1.ebuild,v 1.1 2003/03/09 19:49:14 method Exp $
+
+#cuckoo, cuckoo
+NEWP=${P}-gamma
+
+SVER=${PV%.*}
+#normal releases:
+SDIR=MySQL-${SVER}
+#for a pre-release:
+#SDIR=MySQL-${SVER}-Pre
+
+S=${WORKDIR}/${NEWP}
+
+DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
+HOMEPAGE="http://www.mysql.com/"
+SRC_URI="ftp://mirror.mcs.anl.gov/pub/mysql/Downloads/${SDIR}/${NEWP}.tar.gz
+ ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR}/${NEWP}.tar.gz
+ ftp://mysql.valueclick.com/pub/mysql/Downloads/${SDIR}/${NEWP}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static readline innodb berkdb tcpd ssl"
+
+#HEY!
+#the benchmark stuff in /usr/share/mysql/sql-bench and the
+#/usr/bin/mysql_setpermission script need dev-perl/DBD-mysql.
+#Can't add it here: circ depend. Emerge it either before or
+#after mysql; easier before, then it pulls in mysql.
+
+DEPEND="readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ >=sys-libs/zlib-1.1.3
+ sys-devel/perl
+ sys-apps/procps"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ #required for qmail-mysql
+ patch -p0 < ${FILESDIR}/mysql-4.0-nisam.h.diff || die
+ #zap startup script messages
+ patch -p1 < ${FILESDIR}/mysql-4.0.4-install-db-sh.diff || die
+ #zap binary distribution stuff
+ patch -p1 < ${FILESDIR}/mysql-4.0-mysqld-safe-sh.diff || die
+ #for correct hardcoded sysconf directory
+ patch -p1 < ${FILESDIR}/mysql-4.0-my-print-defaults.diff || die
+ #patch -p1 < ${FILESDIR}/mysql-3.23.51-tcpd.patch || die
+}
+
+src_compile() {
+ local myconf
+ #The following fix is due to a bug with bdb on sparc's. See:
+ #http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
+ if use sparc || use sparc64 || use alpha || use hppa
+ then
+ myconf="${myconf} --without-berkeley-db"
+ else
+ use berkdb && myconf="${myconf} --with-berkeley-db=./bdb"
+ use berkdb || myconf="${myconf} --without-berkeley-db"
+ fi
+ #readline pair reads backwards on purpose, DONT change it around, Ok?
+ use readline && myconf="${myconf} --without-readline"
+ use readline || myconf="${myconf} --with-readline"
+ use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
+ use static || myconf="${myconf} --enable-shared --enable-static"
+ use tcpd && myconf="${myconf} --with-libwrap"
+ use tcpd || myconf="${myconf} --without-libwrap"
+ use innodb && myconf="${myconf} --with-innodb"
+ use innodb || myconf="${myconf} --without-innodb"
+ use ssl && myconf="${myconf} --with-vio --with-openssl"
+ use ssl || myconf="${myconf} --without-openssl"
+ [ -n "${DEBUGBUILD}" ] && myconf="${myconf} --with-debug"
+ [ -n "${DEBUGBUILD}" ] || myconf="${myconf} --without-debug"
+
+ #glibc-2.3.2_pre fix; bug #16496
+ export CFLAGS="${CFLAGS} -DHAVE_ERRNO_AS_DEFINE=1"
+
+ #bug fix for #15099, should make this api backward compatible, thanks dragon
+ export CFLAGS="${CFLAGS} -DUSE_OLD_FUNCTIONS"
+
+ #the compiler flags are as per their "official" spec ;)
+ CFLAGS="${CFLAGS/-O?/} -O3" \
+ CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
+ econf \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/lib/mysql \
+ --with-raid \
+ --with-low-memory \
+ --enable-assembler \
+ --with-charset=latin1 \
+ --enable-local-infile \
+ --with-mysqld-user=mysql \
+ --with-extra-charsets=all \
+ --enable-thread-safe-client \
+ --with-client-ldflags=-lstdc++ \
+ --with-comment="Gentoo ${PF}.ebuild package" \
+ --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
+ ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
+
+ #eeek, not sure whats going on here.. are these needed by anything?
+# use innodb && insinto /usr/lib/mysql && doins ${WORKDIR}/../libs/*
+
+ #move client libs, install a couple of missing headers
+ mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
+ dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
+ dosym ../libmysqlclient_r.so /usr/lib/mysql/libmysqlclient_r.so
+ insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
+
+ #convenience links
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
+
+ #while my broom gently sweeps...
+ rm -f ${D}/usr/share/mysql/binary-configure
+ rm -f ${D}/usr/share/mysql/mysql.server
+ rm -f ${D}/usr/share/mysql/make_binary_distribution
+ rm -f ${D}/usr/share/mysql/mi_test_all*
+ rm -f ${D}/usr/share/mysql/mysql-log-rotate
+ rm -f ${D}/usr/share/mysql/mysql*.spec
+ rm -f ${D}/usr/share/mysql/my-*.cnf
+
+ dodoc README COPYING COPYING.LIB MIRRORS Docs/{manual.ps,manual.txt}
+ docinto conf-samples ; dodoc support-files/my-*.cnf
+ dohtml -r Docs/*
+
+ insinto /etc/mysql
+ doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mysql-4.0.rc6 mysql
+}
+
+pkg_config() {
+ if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
+ einfo "Press ENTER to create the mysql database and set proper"
+ einfo "permissions on it, or Control-C to abort now..."
+ read
+ ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
+ else
+ einfo "Hmm, it appears as though you already have the mysql"
+ einfo "database in place. If you are having problems trying"
+ einfo "to start mysqld, perhaps you need to manually run"
+ einfo "/usr/bin/mysql_install_db and/or check your config"
+ einfo "file(s) and/or database(s) and/or logfile(s)."
+ fi
+}
+
+pkg_preinst() {
+ if ! groupmod mysql; then
+ groupadd -g 60 mysql || die "problem adding group mysql"
+ fi
+
+ if ! id mysql; then
+ useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
+ assert "problem adding user mysql"
+ fi
+}
+
+pkg_postinst() {
+ #empty dirs...
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ #secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql.mysql ${ROOT}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
+
+ #your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
+}